summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2011-02-09 16:00:08 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-12 00:30:28 +0000
commite56f63a2843e5a7d70fd60e0aaed4d962a277da7 (patch)
tree1b1d1bd2cab1a531e5f5d3a476fd75be7e7d6a7e /meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
parent293b023361580cdf41cf8aa0d8e96fd9c380e424 (diff)
downloadpoky-e56f63a2843e5a7d70fd60e0aaed4d962a277da7.tar.gz
openjade: fix build issues
* Recipe is now -native only * Fix install failure due to missing install path * Removed recipe cruft that was not needed, simplifying it * Removed unnecessary patches * Improved patch comment for makefile.patch Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-devtools/openjade/openjade-native_1.3.2.bb')
-rw-r--r--meta/recipes-devtools/openjade/openjade-native_1.3.2.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
new file mode 100644
index 0000000000..f267fc5483
--- /dev/null
+++ b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Tools for working with DSSSL stylesheets for SGML and XML documents"
2DESCRIPTION = "OpenJade is a suite of tools for validating, \
3processing, and applying DSSSL (Document Style Semantics and \
4Specification Language) stylesheets to SGML and XML documents."
5HOMEPAGE = "http://openjade.sourceforge.net"
6SECTION = "base"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
9
10PR = "r0"
11
12DEPENDS = "opensp-native sgml-common-native"
13RDEPENDS_${PN} = "sgml-common"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
16 file://makefile.patch"
17
18SRC_URI[md5sum] = "7df692e3186109cc00db6825b777201e"
19SRC_URI[sha256sum] = "1d2d7996cc94f9b87d0c51cf0e028070ac177c4123ecbfd7ac1cb8d0b7d322d1"
20
21inherit autotools native
22
23EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
24 --enable-splibdir=${STAGING_LIBDIR}"
25
26CFLAGS =+ "-I${S}/include"
27
28do_install() {
29 # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html
30 # for details.
31 install -d ${D}${bindir}
32 install -m 0755 ${S}/jade/.libs/openjade ${D}${bindir}/openjade
33 ln -sf openjade ${D}${bindir}/jade
34
35 oe_libinstall -a -so -C style libostyle ${D}${libdir}
36 oe_libinstall -a -so -C spgrove libospgrove ${D}${libdir}
37 oe_libinstall -a -so -C grove libogrove ${D}${libdir}
38
39 install -d ${D}${datadir}/sgml/openjade-${PV}
40 install -m 644 dsssl/catalog ${D}${datadir}/sgml/openjade-${PV}
41 install -m 644 dsssl/*.{dtd,dsl,sgm} ${D}${datadir}/sgml/openjade-${PV}
42
43 # The catalog must live in the sysroot and it must be there for
44 # install-catalog to do its thing.
45 install -d ${datadir}/sgml/openjade-${PV}
46 install -m 644 dsssl/catalog ${datadir}/sgml/openjade-${PV}/catalog
47 install-catalog --add ${sysconfdir}/sgml/openjade-${PV}.cat \
48 ${datadir}/sgml/openjade-${PV}/catalog
49
50 install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat \
51 ${sysconfdir}/sgml/openjade-${PV}.cat
52}