summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.13.03.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-15 12:28:38 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-16 18:05:40 +0000
commit049027e16d03fa51484265313588baf1df013e60 (patch)
tree0f65c5230255adefdf65b602c10b18518b601ca9 /meta/recipes-devtools/nasm/nasm_2.13.03.bb
parent406ea737f1ce5bb5fed46c8cbeb5c7c13bf3b8ad (diff)
downloadpoky-049027e16d03fa51484265313588baf1df013e60.tar.gz
nasm: Upgrade 2.13.02 -> 2.13.03
(From OE-Core rev: a1e732fac218e6620fe5b515b5b3f3b139bea76d) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.13.03.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.13.03.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.13.03.bb b/meta/recipes-devtools/nasm/nasm_2.13.03.bb
new file mode 100644
index 0000000000..3a47fc9c88
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.13.03.bb
@@ -0,0 +1,28 @@
1SUMMARY = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5
6SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
7
8SRC_URI[md5sum] = "0c581d482f39d5111879ca9601938f74"
9SRC_URI[sha256sum] = "63ec86477ad3f0f6292325fd89e1d93aea2e2fd490070863f17d48f7cd387011"
10
11inherit autotools-brokensep
12
13do_configure_prepend () {
14 if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
15 mv ${S}/aclocal.m4 ${S}/acinclude.m4
16 fi
17}
18
19do_install() {
20 install -d ${D}${bindir}
21 install -d ${D}${mandir}/man1
22
23 oe_runmake 'INSTALLROOT=${D}' install
24}
25
26BBCLASSEXTEND = "native"
27
28DEPENDS = "groff-native"