summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.11.08.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-28 01:51:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-30 22:26:12 +0100
commit23371df9d697cf83a2db545463a37a75d060665a (patch)
tree96a5989d78697f1e0b0b1fa61420feb5978dbe1b /meta/recipes-devtools/nasm/nasm_2.11.08.bb
parentb47ef4ff7ecccabbdc9b383e0c883693d2f38e8e (diff)
downloadpoky-23371df9d697cf83a2db545463a37a75d060665a.tar.gz
nasm: 2.11.06 -> 2.11.08
(From OE-Core rev: 0ebf49f56571d5e1951d47f479ab9713442e30bc) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.11.08.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.11.08.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.11.08.bb b/meta/recipes-devtools/nasm/nasm_2.11.08.bb
new file mode 100644
index 0000000000..e0724e68ad
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.11.08.bb
@@ -0,0 +1,30 @@
1SUMMARY = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
6
7
8SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
9
10SRC_URI[md5sum] = "7aae5cb8e03fac48029c82a7470ab066"
11SRC_URI[sha256sum] = "9da3a0291a0bdc06305b7ba194f1e2c2b55ae6f11210b4af43729868149d5445"
12
13inherit autotools-brokensep
14
15do_configure_prepend () {
16 if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
17 mv ${S}/aclocal.m4 ${S}/acinclude.m4
18 fi
19}
20
21do_install() {
22 install -d ${D}${bindir}
23 install -d ${D}${mandir}/man1
24
25 oe_runmake 'INSTALLROOT=${D}' install
26}
27
28BBCLASSEXTEND = "native"
29
30DEPENDS = "groff-native"