summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.10.09.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-07-30 11:40:16 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-03 10:33:05 +0100
commite4a6815e446f09f9f38743422c443fc8ab35a810 (patch)
tree8a0a072c22515b124da574a6b006365782db4381 /meta/recipes-devtools/nasm/nasm_2.10.09.bb
parent8bebf2b04da94cd1f21cd17a53898182c1b46e56 (diff)
downloadpoky-e4a6815e446f09f9f38743422c443fc8ab35a810.tar.gz
nasm: upgrade to 2.10.09
(From OE-Core rev: ef79df58e715c411db7726713c46b4504bba4a8e) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.10.09.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.10.09.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.10.09.bb b/meta/recipes-devtools/nasm/nasm_2.10.09.bb
new file mode 100644
index 0000000000..19663d6be7
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.10.09.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
6
7
8SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
9SRC_URI[md5sum] = "0e45ca0d3d7ff36d503777eaa673e2ae"
10SRC_URI[sha256sum] = "7141180d3874b5967c6a60191e8d45fba9cc86bd60a4803ad80b6b6b3eac36b9"
11
12inherit autotools
13
14do_configure_prepend () {
15 if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
16 mv ${S}/aclocal.m4 ${S}/acinclude.m4
17 fi
18}
19
20do_install() {
21 install -d ${D}${bindir}
22 install -d ${D}${mandir}/man1
23
24 oe_runmake 'INSTALLROOT=${D}' install
25}
26
27BBCLASSEXTEND = "native"
28
29DEPENDS = "groff-native"