summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
diff options
context:
space:
mode:
authorChristopher Larson <chris_larson@mentor.com>2016-05-23 14:19:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-25 07:50:17 +0100
commit8a97d9ef923355956ec08be0aff9428a1573884d (patch)
tree2d037c199c7f5325b4f5229cd50e34f4bc326cae /meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
parent06563e639fe089f5e836132fb1aa699a1ba156aa (diff)
downloadpoky-8a97d9ef923355956ec08be0aff9428a1573884d.tar.gz
mkelfimage: fix compile issues
This fixes a couple issues introduced by the previous patch. There were a couple spots where HOST_CFLAGS needed changing to CFLAGS. This fixes builds with security_flags. (From OE-Core rev: 72792a2fd900fe86d18bd8e330bc0535e2eeb80d) Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/mkelfimage/mkelfimage_git.bb')
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage_git.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
index d7a4429fb8..2bcc8d7bd9 100644
--- a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
@@ -24,8 +24,11 @@ CLEANBROKEN = "1"
24S = "${WORKDIR}/git/util/mkelfImage" 24S = "${WORKDIR}/git/util/mkelfImage"
25 25
26CFLAGS += "-fno-stack-protector" 26CFLAGS += "-fno-stack-protector"
27CACHED_CONFIGUREVARS += "HOST_CC='${BUILD_CC}'" 27CACHED_CONFIGUREVARS += "\
28EXTRA_OEMAKE += "HOST_CPPFLAGS='${BUILD_CPPFLAGS}'" 28 HOST_CC='${BUILD_CC}' \
29 HOST_CFLAGS='${BUILD_CFLAGS}' \
30 HOST_CPPFLAGS='${BUILD_CPPFLAGS}' \
31"
29 32
30inherit autotools-brokensep 33inherit autotools-brokensep
31 34