summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2017-08-31 15:43:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-02 00:52:10 +0100
commitd69a8766521c0cdac509cde61f5c201c92a9f8ba (patch)
treea6541d64984592a352af6812dd05c730debc1895 /meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
parent69c06b16943737392e86d47a02e280a21db08474 (diff)
downloadpoky-d69a8766521c0cdac509cde61f5c201c92a9f8ba.tar.gz
mkelfimage: Add update convert.bin.c file
This is a compile code fragment that has an elf signature, it needs to be updated for the newer tools. After 2.4 we will be removing the elf Image type as it has been expunged from the coreboot repo since 2014. [YOCTO #11967] (From OE-Core rev: 66f7ec30a05639739208bb921b689e94b2c880a3) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/mkelfimage/mkelfimage_git.bb')
-rw-r--r--meta/recipes-devtools/mkelfimage/mkelfimage_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
index 05a5a1a489..330fa7c9a7 100644
--- a/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
+++ b/meta/recipes-devtools/mkelfimage/mkelfimage_git.bb
@@ -17,6 +17,7 @@ SRC_URI = "git://review.coreboot.org/p/coreboot;protocol=http \
17 " 17 "
18SRC_URI_append_class-native = " \ 18SRC_URI_append_class-native = " \
19 file://fix-makefile-to-find-libz.patch \ 19 file://fix-makefile-to-find-libz.patch \
20 file://convert.bin.c \
20" 21"
21 22
22CLEANBROKEN = "1" 23CLEANBROKEN = "1"
@@ -34,6 +35,10 @@ EXTRA_OECONF_append_x86-64 = " --with-i386=${HOST_SYS}"
34 35
35inherit autotools-brokensep 36inherit autotools-brokensep
36 37
38do_configure_prepend-class-native() {
39 cp ${WORKDIR}/convert.bin.c ${S}/linux-i386/
40}
41
37do_install_append() { 42do_install_append() {
38 rmdir ${D}${datadir}/mkelfImage/elf32-i386 43 rmdir ${D}${datadir}/mkelfImage/elf32-i386
39 rmdir ${D}${datadir}/mkelfImage 44 rmdir ${D}${datadir}/mkelfImage