summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/meson/nativesdk-meson_0.49.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2019-02-19 18:46:58 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-20 11:30:35 +0000
commitf8b41db6908205e4cd4dcc5ed673fe4959cfdee6 (patch)
tree8cb6c97e7a199ac9f36edbf50e401e84f67c2bb0 /meta/recipes-devtools/meson/nativesdk-meson_0.49.2.bb
parent215b6417650223de941773a087ec71541d879040 (diff)
downloadpoky-f8b41db6908205e4cd4dcc5ed673fe4959cfdee6.tar.gz
meson: upgrade 0.49.0 -> 0.49.2
(From OE-Core rev: 0cc5265d108fd632db9dd751454325fe6e86a62f) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/meson/nativesdk-meson_0.49.2.bb')
-rw-r--r--meta/recipes-devtools/meson/nativesdk-meson_0.49.2.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-devtools/meson/nativesdk-meson_0.49.2.bb b/meta/recipes-devtools/meson/nativesdk-meson_0.49.2.bb
new file mode 100644
index 0000000000..1549357a55
--- /dev/null
+++ b/meta/recipes-devtools/meson/nativesdk-meson_0.49.2.bb
@@ -0,0 +1,71 @@
1include meson.inc
2
3inherit nativesdk
4inherit siteinfo
5
6SRC_URI += "file://meson-setup.py \
7 file://meson-wrapper"
8
9def meson_endian(prefix, d):
10 arch, os = d.getVar(prefix + "_ARCH"), d.getVar(prefix + "_OS")
11 sitedata = siteinfo_data_for_machine(arch, os, d)
12 if "endian-little" in sitedata:
13 return "little"
14 elif "endian-big" in sitedata:
15 return "big"
16 else:
17 bb.fatal("Cannot determine endianism for %s-%s" % (arch, os))
18
19MESON_TOOLCHAIN_ARGS = "${BUILDSDK_CC_ARCH}${TOOLCHAIN_OPTIONS}"
20MESON_C_ARGS = "${MESON_TOOLCHAIN_ARGS} ${BUILDSDK_CFLAGS}"
21MESON_CPP_ARGS = "${MESON_TOOLCHAIN_ARGS} ${BUILDSDK_CXXFLAGS}"
22MESON_LINK_ARGS = "${MESON_TOOLCHAIN_ARGS} ${BUILDSDK_LDFLAGS}"
23
24# The cross file logic is similar but not identical to that in meson.bbclass,
25# since it's generating for an SDK rather than a cross-compile. Important
26# differences are:
27# - We can't set vars like CC, CXX, etc. yet because they will be filled in with
28# real paths by meson-setup.sh when the SDK is extracted.
29# - Some overrides aren't needed, since the SDK injects paths that take care of
30# them.
31do_install_append() {
32 install -d ${D}${datadir}/meson
33 cat >${D}${datadir}/meson/meson.cross.template <<EOF
34[binaries]
35c = @CC
36cpp = @CXX
37ar = @AR
38nm = @NM
39ld = @LD
40strip = @STRIP
41pkgconfig = 'pkg-config'
42
43[properties]
44needs_exe_wrapper = true
45c_args = @CFLAGS
46c_link_args = @LDFLAGS
47cpp_args = @CPPFLAGS
48cpp_link_args = @LDFLAGS
49
50[host_machine]
51system = '${SDK_OS}'
52cpu_family = '${SDK_ARCH}'
53cpu = '${SDK_ARCH}'
54endian = '${@meson_endian("SDK", d)}'
55EOF
56
57 install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d
58 install -m 0755 ${WORKDIR}/meson-setup.py ${D}${SDKPATHNATIVE}/post-relocate-setup.d/
59
60 # We need to wrap the real meson with a thin env setup wrapper.
61 mv ${D}${bindir}/meson ${D}${bindir}/meson.real
62 install -m 0755 ${WORKDIR}/meson-wrapper ${D}${bindir}/meson
63}
64
65RDEPENDS_${PN} += "\
66 nativesdk-ninja \
67 nativesdk-python3 \
68 nativesdk-python3-setuptools \
69 "
70
71FILES_${PN} += "${datadir}/meson ${SDKPATHNATIVE}"