diff options
author | Ross Burton <ross.burton@intel.com> | 2019-01-07 16:37:03 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-01-08 11:16:45 +0000 |
commit | 5a0bed5be6fe2a62480c0a5fdddd1d99e599d4f9 (patch) | |
tree | 875b26a1341a3e8705f6c044da80e51e91ea1749 /meta/recipes-devtools/meson/nativesdk-meson_0.49.0.bb | |
parent | c2556c44ecfb21c3fefddf12f9d9abdf482b90c7 (diff) | |
download | poky-5a0bed5be6fe2a62480c0a5fdddd1d99e599d4f9.tar.gz |
meson: write correct host endian into SDK cross file
Meson doesn't ignore this but will emit a warning, so write the correct value.
(From OE-Core rev: 1239157805a4c363da853de6db05c53083b01189)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/meson/nativesdk-meson_0.49.0.bb')
-rw-r--r-- | meta/recipes-devtools/meson/nativesdk-meson_0.49.0.bb | 15 |
1 files changed, 11 insertions, 4 deletions
diff --git a/meta/recipes-devtools/meson/nativesdk-meson_0.49.0.bb b/meta/recipes-devtools/meson/nativesdk-meson_0.49.0.bb index 55c57775e0..1549357a55 100644 --- a/meta/recipes-devtools/meson/nativesdk-meson_0.49.0.bb +++ b/meta/recipes-devtools/meson/nativesdk-meson_0.49.0.bb | |||
@@ -1,13 +1,20 @@ | |||
1 | include meson.inc | 1 | include meson.inc |
2 | 2 | ||
3 | inherit nativesdk | 3 | inherit nativesdk |
4 | inherit siteinfo | ||
4 | 5 | ||
5 | SRC_URI += "file://meson-setup.py \ | 6 | SRC_URI += "file://meson-setup.py \ |
6 | file://meson-wrapper" | 7 | file://meson-wrapper" |
7 | 8 | ||
8 | # both are required but not used by meson | 9 | def meson_endian(prefix, d): |
9 | MESON_SDK_ENDIAN = "bogus-endian" | 10 | arch, os = d.getVar(prefix + "_ARCH"), d.getVar(prefix + "_OS") |
10 | MESON_TARGET_ENDIAN = "bogus-endian" | 11 | sitedata = siteinfo_data_for_machine(arch, os, d) |
12 | if "endian-little" in sitedata: | ||
13 | return "little" | ||
14 | elif "endian-big" in sitedata: | ||
15 | return "big" | ||
16 | else: | ||
17 | bb.fatal("Cannot determine endianism for %s-%s" % (arch, os)) | ||
11 | 18 | ||
12 | MESON_TOOLCHAIN_ARGS = "${BUILDSDK_CC_ARCH}${TOOLCHAIN_OPTIONS}" | 19 | MESON_TOOLCHAIN_ARGS = "${BUILDSDK_CC_ARCH}${TOOLCHAIN_OPTIONS}" |
13 | MESON_C_ARGS = "${MESON_TOOLCHAIN_ARGS} ${BUILDSDK_CFLAGS}" | 20 | MESON_C_ARGS = "${MESON_TOOLCHAIN_ARGS} ${BUILDSDK_CFLAGS}" |
@@ -44,7 +51,7 @@ cpp_link_args = @LDFLAGS | |||
44 | system = '${SDK_OS}' | 51 | system = '${SDK_OS}' |
45 | cpu_family = '${SDK_ARCH}' | 52 | cpu_family = '${SDK_ARCH}' |
46 | cpu = '${SDK_ARCH}' | 53 | cpu = '${SDK_ARCH}' |
47 | endian = '${MESON_SDK_ENDIAN}' | 54 | endian = '${@meson_endian("SDK", d)}' |
48 | EOF | 55 | EOF |
49 | 56 | ||
50 | install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d | 57 | install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d |