summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/meson/meson_0.44.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-01-04 15:12:30 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-05 11:55:35 +0000
commit0d2020fcffa00cc2464ce80e749fe99b9dfab2a0 (patch)
treea75b4e792e2ea6ab8293a3c9806816cc33ee7878 /meta/recipes-devtools/meson/meson_0.44.0.bb
parentf2b03953b28755277437641645669396f285919a (diff)
downloadpoky-0d2020fcffa00cc2464ce80e749fe99b9dfab2a0.tar.gz
meson: add a recipe and class from meta-oe
The original recipe has been provided and improved by: Ross Burton <ross.burton@intel.com> Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Adam C. Foltzer <acfoltzer@galois.com> Peter Kjellerstedt <peter.kjellerstedt@axis.com> Linus Svensson <linussn@axis.com> I have added patches to fix up gtk-doc and gobject-introspection in cross-compilation environments, and also change the order of linker arguments to replicate autotools more closely (and fix linking errors in some corner cases). (From OE-Core rev: 1f8dea686cdfd6d360ba4a97f62d274c39eaeb8e) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/meson/meson_0.44.0.bb')
-rw-r--r--meta/recipes-devtools/meson/meson_0.44.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/meson/meson_0.44.0.bb b/meta/recipes-devtools/meson/meson_0.44.0.bb
new file mode 100644
index 0000000000..9b4c7e6ab1
--- /dev/null
+++ b/meta/recipes-devtools/meson/meson_0.44.0.bb
@@ -0,0 +1,20 @@
1HOMEPAGE = "http://mesonbuild.com"
2SUMMARY = "A high performance build system"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI = "https://github.com/mesonbuild/meson/releases/download/${PV}/${BP}.tar.gz \
8 file://0001-gtkdoc-fix-issues-that-arise-when-cross-compiling.patch \
9 file://0002-gobject-introspection-determine-g-ir-scanner-and-g-i.patch \
10 file://0001-Linker-rules-move-cross_args-in-front-of-output_args.patch \
11 "
12SRC_URI[md5sum] = "26a7ca93ec9cea5facb365664261f9c6"
13SRC_URI[sha256sum] = "50f9b12b77272ef6ab064d26b7e06667f07fa9f931e6a20942bba2216ba4281b"
14UPSTREAM_CHECK_URI = "https://github.com/mesonbuild/meson/releases"
15
16inherit setuptools3
17
18RDEPENDS_${PN} = "ninja python3-core python3-modules"
19
20BBCLASSEXTEND = "native"