diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2019-02-20 21:10:24 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-02-25 11:44:57 +0000 |
commit | 1781289b683fc6ac1a620bbe36f669c905b0f4c7 (patch) | |
tree | 269f1660825255110397d8e24e7f2c9fe33dc56e /meta/recipes-devtools/llvm/llvm_git.bb | |
parent | 11cdf4c5d9dad1abbe019541404e5efcf7279b37 (diff) | |
download | poky-1781289b683fc6ac1a620bbe36f669c905b0f4c7.tar.gz |
llvm: switch to the official git repository
Until now an unoffcial mirror was used, which may or may not
be maintained in the longer run, as the need for it has gone.
Also, the official mirror has version tags which allows us
to track upstream development in an automated manner.
${S} has changed as upstream decided to use a monorepo for all
of the llvm-related projects.
Further info:
https://www.phoronix.com/scan.php?page=news_item&px=LLVM-GitHub-Mono-Repo
https://llvm.org/docs/GettingStarted.html#checkout-llvm-from-git
(From OE-Core rev: 18f565f3ca18c281b4a99721fcfcbcc5405d6346)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r-- | meta/recipes-devtools/llvm/llvm_git.bb | 14 |
1 files changed, 9 insertions, 5 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb index eca78af09e..c68512cc63 100644 --- a/meta/recipes-devtools/llvm/llvm_git.bb +++ b/meta/recipes-devtools/llvm/llvm_git.bb | |||
@@ -19,20 +19,24 @@ PROVIDES += "llvm${PV}" | |||
19 | LLVM_RELEASE = "${PV}" | 19 | LLVM_RELEASE = "${PV}" |
20 | LLVM_DIR = "llvm${LLVM_RELEASE}" | 20 | LLVM_DIR = "llvm${LLVM_RELEASE}" |
21 | 21 | ||
22 | SRCREV = "e5cc6808dc0d5b773479bf36c51d59d0d3174733" | 22 | # SRCREV is set to the revision of 8.0.0-rc2 tag, while latest release |
23 | BRANCH = "release_${MAJOR_VERSION}${MINOR_VERSION}" | 23 | # tag is 7.0.1 as of Feb 18 2019, hence the need for UPSTREAM_CHECK_UNKNOWN |
24 | # Remove the UPSTREAM_VERSION_UNKNOWN line once 8.0.0 final is tagged | ||
25 | UPSTREAM_VERSION_UNKNOWN = "1" | ||
26 | SRCREV = "98ebe7460199b9cd79eb562b5e8705ad28f5513f" | ||
27 | |||
28 | BRANCH = "release/${MAJOR_VERSION}.x" | ||
24 | MAJOR_VERSION = "8" | 29 | MAJOR_VERSION = "8" |
25 | MINOR_VERSION = "0" | 30 | MINOR_VERSION = "0" |
26 | PATCH_VERSION = "0" | 31 | PATCH_VERSION = "0" |
27 | SOLIBVER = "1" | 32 | SOLIBVER = "1" |
28 | PV = "${MAJOR_VERSION}.${MINOR_VERSION}" | 33 | PV = "${MAJOR_VERSION}.${MINOR_VERSION}" |
29 | SRC_URI = "git://github.com/llvm-mirror/llvm.git;branch=${BRANCH} \ | 34 | SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \ |
30 | file://0001-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \ | 35 | file://0001-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch \ |
31 | file://0002-llvm-allow-env-override-of-exe-path.patch \ | 36 | file://0002-llvm-allow-env-override-of-exe-path.patch \ |
32 | " | 37 | " |
33 | UPSTREAM_CHECK_COMMITS = "1" | ||
34 | 38 | ||
35 | S = "${WORKDIR}/git" | 39 | S = "${WORKDIR}/git/llvm" |
36 | 40 | ||
37 | LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install" | 41 | LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install" |
38 | 42 | ||