summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2019-10-08 13:14:21 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-09 14:07:43 +0100
commitfe2c86fc7770c563be9780905f45e7868d712d8f (patch)
tree1abd697949a01966c728abd51e9834a6ba9b4ee2 /meta/recipes-devtools/llvm/llvm_git.bb
parent20916caa295a45e8281e41b7dfaf5ad6025f08eb (diff)
downloadpoky-fe2c86fc7770c563be9780905f45e7868d712d8f.tar.gz
llvm: remove -mlongcall from CXXFLAGS for powerpc
after gcc upgrade to 9.1.0, with this flags will make below error: collect2: fatal error: ld terminated with signal 11 [Segmentation fault] remove it as workaround, after remove it, powerpc can compile successfully (From OE-Core rev: 487eb18928c26e7781bb86a972369f3594ecdcca) Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb2
1 files changed, 0 insertions, 2 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 08b19a33e3..9b113f692f 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -86,8 +86,6 @@ EXTRA_OECMAKE_append_class-nativesdk = "\
86 -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \ 86 -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \
87 " 87 "
88 88
89CXXFLAGS_append_class-target_powerpc = " -mlongcall"
90
91do_configure_prepend() { 89do_configure_prepend() {
92# Fix paths in llvm-config 90# Fix paths in llvm-config
93 sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp 91 sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp