summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb')
-rw-r--r--meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb b/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb
new file mode 100644
index 0000000000..fff15e916d
--- /dev/null
+++ b/meta/recipes-devtools/libtool/nativesdk-libtool_2.4.2.bb
@@ -0,0 +1,35 @@
1require libtool-${PV}.inc
2
3PR = "${INC_PR}.0"
4
5FILESEXTRAPATHS =. "${FILE_DIRNAME}/libtool:"
6
7SRC_URI += "file://prefix.patch"
8SRC_URI += "file://fixinstall.patch"
9
10inherit nativesdk
11
12S = "${WORKDIR}/libtool-${PV}"
13FILES_${PN} += "${datadir}/libtool/*"
14
15do_configure_prepend () {
16 # Remove any existing libtool m4 since old stale versions would break
17 # any upgrade
18 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
19 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
20}
21
22do_install () {
23 autotools_do_install
24 install -d ${D}${bindir}/
25 install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/
26}
27
28SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess"
29
30libtoolnativesdk_sysroot_preprocess () {
31 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
32 install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${bindir_crossscripts}/${HOST_SYS}-libtool
33}
34
35export CONFIG_SHELL="/bin/bash"