summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-11-08 11:10:56 -0800
committerSaul Wold <Saul.Wold@intel.com>2010-11-18 13:30:25 -0800
commit563953df47785bf57969d86b9b5f8494e585a28c (patch)
tree4b9d4cdb858f08894503dcd5233e6bcf5ed7ab6e /meta/recipes-devtools/libtool/libtool-nativesdk_2.4.bb
parentaa5befab23679e07441805e18d9b6f3f271b5ed5 (diff)
downloadpoky-563953df47785bf57969d86b9b5f8494e585a28c.tar.gz
libtool upgrade from 2.2.10 to 2.4
Taking out of this code from patch as the newer upstream code has fix, and this patch is not needed. cross-compile.patch: -Index: libtool-2.2.10/libltdl/config/ltmain.m4sh +Index: libtool-2.4/libltdl/config/ltmain.m4sh =================================================================== ---- libtool-2.2.10.orig/libltdl/config/ltmain.m4sh -+++ libtool-2.2.10/libltdl/config/ltmain.m4sh -@@ -5147,8 +5147,14 @@ func_mode_link () - absdir="$abs_ladir" - libdir="$abs_ladir" - else -- dir="$libdir" -- absdir="$libdir" -+ # Adding 'libdir' from the .la file to our library search paths -+ # breaks crosscompilation horribly. We cheat here and don't add -+ # it, instead adding the path where we found the .la. -CL -+ dir="$abs_ladir" -+ absdir="$abs_ladir" -+ libdir="$abs_ladir" -+ #dir="$libdir" -+ #absdir="$libdir" - fi - test "X$hardcode_automatic" = Xyes && avoidtemprpath=yes - else Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-nativesdk_2.4.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-nativesdk_2.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.bb b/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.bb
new file mode 100644
index 0000000000..c9f24a95bf
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.bb
@@ -0,0 +1,27 @@
1require libtool_${PV}.bb
2
3PR = "r0"
4SRC_URI_append = " file://cross_compile.patch \
5 file://prefix.patch "
6
7inherit nativesdk
8
9do_configure_prepend () {
10 # Remove any existing libtool m4 since old stale versions would break
11 # any upgrade
12 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
13 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
14}
15
16do_install () {
17 autotools_do_install
18 install -d ${D}${bindir}/
19 install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/
20}
21
22SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess"
23
24libtoolnativesdk_sysroot_preprocess () {
25 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
26 install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
27}