summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-native_2.4.2.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
new file mode 100644
index 0000000000..f1051d84f3
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
@@ -0,0 +1,25 @@
1require libtool-${PV}.inc
2
3DEPENDS = ""
4
5PR = "${INC_PR}.1"
6SRC_URI += "file://prefix.patch"
7
8inherit native
9
10EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
11
12do_configure_prepend () {
13 # Remove any existing libtool m4 since old stale versions would break
14 # any upgrade
15 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
16 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
17}
18
19do_install () {
20 autotools_do_install
21 install -d ${D}${bindir}/
22 install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
23}
24
25export CONFIG_SHELL="/bin/bash"