diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-03-17 18:00:05 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-03-23 12:13:49 +0000 |
commit | ff7b41573842a403c81f58bee41fc8163a9d7754 (patch) | |
tree | 942642ee97ef156870d3847cefd7fb4fe7aae49a /meta/recipes-devtools/libtool/libtool-cross_2.4.7.bb | |
parent | 3d62a6cc5c7859a16358d73938752dc8ca4e51ea (diff) | |
download | poky-ff7b41573842a403c81f58bee41fc8163a9d7754.tar.gz |
libtool: Upgrade 2.4.6 -> 2.4.7
Libtool made a release after many years. Update to it, allowing us to drop two
backported patches. We also drop a performance optimistion patch since it is
too invasive to maintain separately.
(From OE-Core rev: b5d13cbdded0f71fd4b847066434d30e8a39c9ce)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-cross_2.4.7.bb')
-rw-r--r-- | meta/recipes-devtools/libtool/libtool-cross_2.4.7.bb | 50 |
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-cross_2.4.7.bb b/meta/recipes-devtools/libtool/libtool-cross_2.4.7.bb new file mode 100644 index 0000000000..93f1dd7825 --- /dev/null +++ b/meta/recipes-devtools/libtool/libtool-cross_2.4.7.bb | |||
@@ -0,0 +1,50 @@ | |||
1 | require libtool-${PV}.inc | ||
2 | |||
3 | PACKAGES = "" | ||
4 | SRC_URI += "file://fixinstall.patch" | ||
5 | |||
6 | datadir = "${STAGING_DIR_TARGET}${target_datadir}" | ||
7 | |||
8 | inherit nopackages | ||
9 | |||
10 | do_configure:prepend () { | ||
11 | # Remove any existing libtool m4 since old stale versions would break | ||
12 | # any upgrade | ||
13 | rm -f ${STAGING_DATADIR}/aclocal/libtool.m4 | ||
14 | rm -f ${STAGING_DATADIR}/aclocal/lt*.m4 | ||
15 | } | ||
16 | |||
17 | # | ||
18 | # ccache may or may not be INHERITED, we remove references to it so the sstate | ||
19 | # artefact works on a machine where its not present. libtool-cross isn't used | ||
20 | # heavily so any performance issue is minor. | ||
21 | # Find references to LTCC="ccache xxx-gcc" and CC="ccache xxx-gcc" | ||
22 | # | ||
23 | do_install () { | ||
24 | ln -s false ${D} | ||
25 | install -d ${D}${bindir_crossscripts}/ | ||
26 | install -m 0755 libtool ${D}${bindir_crossscripts}/libtool | ||
27 | sed -e 's@^\(predep_objects="\).*@\1"@' \ | ||
28 | -e 's@^\(postdep_objects="\).*@\1"@' \ | ||
29 | -e 's@^CC="ccache.@CC="@' \ | ||
30 | -e 's@^LTCC="ccache.@LTCC="@' \ | ||
31 | -i ${D}${bindir_crossscripts}/libtool | ||
32 | sed -i '/^archive_cmds=/s/\-nostdlib//g' ${D}${bindir_crossscripts}/libtool | ||
33 | sed -i '/^archive_expsym_cmds=/s/\-nostdlib//g' ${D}${bindir_crossscripts}/libtool | ||
34 | GREP='/bin/grep' SED='sed' ${S}/build-aux/inline-source libtoolize > ${D}${bindir_crossscripts}/libtoolize | ||
35 | chmod 0755 ${D}${bindir_crossscripts}/libtoolize | ||
36 | install -d ${D}${target_datadir}/libtool/build-aux/ | ||
37 | install -d ${D}${target_datadir}/aclocal/ | ||
38 | install -c ${S}/build-aux/compile ${D}${target_datadir}/libtool/build-aux/ | ||
39 | install -c ${S}/build-aux/config.guess ${D}${target_datadir}/libtool/build-aux/ | ||
40 | install -c ${S}/build-aux/config.sub ${D}${target_datadir}/libtool/build-aux/ | ||
41 | install -c ${S}/build-aux/depcomp ${D}${target_datadir}/libtool/build-aux/ | ||
42 | install -c ${S}/build-aux/install-sh ${D}${target_datadir}/libtool/build-aux/ | ||
43 | install -c ${S}/build-aux/missing ${D}${target_datadir}/libtool/build-aux/ | ||
44 | install -c -m 0644 ${S}/build-aux/ltmain.sh ${D}${target_datadir}/libtool/build-aux/ | ||
45 | install -c -m 0644 ${S}/m4/*.m4 ${D}${target_datadir}/aclocal/ | ||
46 | } | ||
47 | |||
48 | SYSROOT_DIRS += "${bindir_crossscripts} ${target_datadir}" | ||
49 | |||
50 | SSTATE_SCAN_FILES += "libtoolize *-libtool" | ||