diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-08-10 10:10:15 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-08-14 11:36:31 +0100 |
commit | 0472cc2368cc7beab8ee18ac4320868980406929 (patch) | |
tree | 313540536a6c5254bd53d235e22f953b841ce4e0 /meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb | |
parent | 79457a3e2b30202d3f000d87661e9d60d28f1d0b (diff) | |
download | poky-0472cc2368cc7beab8ee18ac4320868980406929.tar.gz |
libtool-cross: Handle ccache sstate 'infection' issues
On a system without ccache, f you:
INHERIT += "ccache"
bitbake libtool-cross
<remove INHERIT>
bitbake apmd
then it fails due to being unable to find ccache. The references to ccache are
coded into libtool-cross but the sstate checksum doesn't reflect this due to the
way the class is coded (output should be the same regardless).
The simplest solution is to remove references to ccache from the libtool script.
The output then works regardless of whether ccache is present or not. The
libtool-cross script is only used in a handful of cases (most of the time its
dynamically generated by autoconf) so any performance issue is minor.
(From OE-Core rev: ed550a49d2114c56e5bc033ecd0e83073d2d4067)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb')
-rw-r--r-- | meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb | 8 |
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb b/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb index b268310468..522bf3a0e9 100644 --- a/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb +++ b/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb | |||
@@ -13,11 +13,19 @@ do_configure_prepend () { | |||
13 | rm -f ${STAGING_DATADIR}/aclocal/lt*.m4 | 13 | rm -f ${STAGING_DATADIR}/aclocal/lt*.m4 |
14 | } | 14 | } |
15 | 15 | ||
16 | # | ||
17 | # ccache may or may not be INHERITED, we remove references to it so the sstate | ||
18 | # artefact works on a machine where its not present. libtool-cross isn't used | ||
19 | # heavily so any performance issue is minor. | ||
20 | # Find references to LTCC="ccache xxx-gcc" and CC="ccache xxx-gcc" | ||
21 | # | ||
16 | do_install () { | 22 | do_install () { |
17 | install -d ${D}${bindir_crossscripts}/ | 23 | install -d ${D}${bindir_crossscripts}/ |
18 | install -m 0755 ${HOST_SYS}-libtool ${D}${bindir_crossscripts}/${HOST_SYS}-libtool | 24 | install -m 0755 ${HOST_SYS}-libtool ${D}${bindir_crossscripts}/${HOST_SYS}-libtool |
19 | sed -e 's@^\(predep_objects="\).*@\1"@' \ | 25 | sed -e 's@^\(predep_objects="\).*@\1"@' \ |
20 | -e 's@^\(postdep_objects="\).*@\1"@' \ | 26 | -e 's@^\(postdep_objects="\).*@\1"@' \ |
27 | -e 's@^CC="ccache.@CC="@' \ | ||
28 | -e 's@^LTCC="ccache.@LTCC="@' \ | ||
21 | -i ${D}${bindir_crossscripts}/${HOST_SYS}-libtool | 29 | -i ${D}${bindir_crossscripts}/${HOST_SYS}-libtool |
22 | sed -i '/^archive_cmds=/s/\-nostdlib//g' ${D}${bindir_crossscripts}/${HOST_SYS}-libtool | 30 | sed -i '/^archive_cmds=/s/\-nostdlib//g' ${D}${bindir_crossscripts}/${HOST_SYS}-libtool |
23 | sed -i '/^archive_expsym_cmds=/s/\-nostdlib//g' ${D}${bindir_crossscripts}/${HOST_SYS}-libtool | 31 | sed -i '/^archive_expsym_cmds=/s/\-nostdlib//g' ${D}${bindir_crossscripts}/${HOST_SYS}-libtool |