summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libdnf/libdnf_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-12-30 18:57:22 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-14 14:42:16 +0000
commit374494e746e58d4efa308d0baf52a56ca5b72fb2 (patch)
treeb01f691e0a9ca48bb6d0339c3e9cbf81a6d41d08 /meta/recipes-devtools/libdnf/libdnf_git.bb
parentbbddf83f65f490c88130d794c53ff9e4c45d0693 (diff)
downloadpoky-374494e746e58d4efa308d0baf52a56ca5b72fb2.tar.gz
libdnf: add a recipe
libdnf is required by dnf. (From OE-Core rev: 8ac3fb682928aeb076c8f78fb429936ae747bc77) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/libdnf/libdnf_git.bb')
-rw-r--r--meta/recipes-devtools/libdnf/libdnf_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libdnf/libdnf_git.bb b/meta/recipes-devtools/libdnf/libdnf_git.bb
new file mode 100644
index 0000000000..681c0029c5
--- /dev/null
+++ b/meta/recipes-devtools/libdnf/libdnf_git.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Library providing simplified C and Python API to libsolv"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
4
5SRC_URI = "git://github.com/rpm-software-management/libdnf \
6 file://0001-FindGtkDoc.cmake-drop-the-requirement-for-GTKDOC_SCA.patch \
7 file://0002-Prefix-sysroot-path-to-introspection-tools-path.patch \
8 file://0003-Set-the-library-installation-directory-correctly.patch \
9 file://0004-Set-libsolv-variables-with-pkg-config-cmake-s-own-mo.patch \
10 file://0001-Get-parameters-for-both-libsolv-and-libsolvext-libdn.patch \
11 "
12
13PV = "0.2.3+git${SRCPV}"
14SRCREV = "367545629cc01a8e622890d89bd13d062ce60d7b"
15
16S = "${WORKDIR}/git"
17
18DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc"
19
20inherit gtk-doc gobject-introspection cmake pkgconfig
21
22# We cannot inherit pythonnative (or descendant classes like distutils etc.)
23# because that would conflict with inheriting python3native
24# (which is done by inheriting gobject-introspection).
25# But libdnf only needs the path to native Python 2.x binary
26# so we simply set it explicitly here.
27#
28# These lines can be dropped when dnf stack is moved to python 3.x
29EXTRANATIVEPATH += "python-native"
30FILES_${PN} += " ${libdir}/python2.7/*"
31DEPENDS += "python-native"
32
33EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DWITH_MAN=OFF \
34 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DWITH_GIR=ON', '-DWITH_GIR=OFF', d)} \
35 "
36EXTRA_OECMAKE_append_class-native = " -DWITH_GIR=OFF"
37EXTRA_OECMAKE_append_class-nativesdk = " -DWITH_GIR=OFF"
38
39BBCLASSEXTEND = "native"
40