summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-11-13 21:32:47 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-11-18 16:42:06 +0000
commitbc80f0e5074780421963714c7980974ed35423d8 (patch)
treef202201a0adb0e7d19908f6ddb4589416b743742 /meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb
parent113852387e0785677926b4b253862e9fea732170 (diff)
downloadpoky-bc80f0e5074780421963714c7980974ed35423d8.tar.gz
kconfig-frontends: Update to 3.6
(From OE-Core rev: 3fb19c1044b46ee7b0d898af4fc6f46bbd957b2f) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb
new file mode 100644
index 0000000000..d1fdc0e297
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb
@@ -0,0 +1,41 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "The kconfig-frontends project aims at centralising \
5the effort of keeping an up-to-date, out-of-tree, packaging of the \
6kconfig infrastructure, ready for use by third-party projects. \
7The kconfig-frontends package provides the kconfig parser, as well as all \
8the frontends"
9HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
12SECTION = "devel"
13DEPENDS += "ncurses flex bison gperf"
14PR = "r0"
15PV = "3.6.0"
16SPIN = "0"
17SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}-${SPIN}.tar.xz"
18
19SRC_URI[md5sum] = "91ca87abb3c99c3fd40a7babb05ec507"
20SRC_URI[sha256sum] = "3084989a9b146688f318b5524dfb7ab3ba47c9cef355d1aebaa520befdb48da0"
21
22S = "${WORKDIR}/${BPN}-${PV}-${SPIN}"
23
24inherit autotools
25do_configure_prepend () {
26 mkdir -p scripts/.autostuff/m4
27}
28
29do_install_append() {
30 ln -s kconfig-conf ${D}${bindir}/conf
31 ln -s kconfig-mconf ${D}${bindir}/mconf
32}
33
34EXTRA_OECONF += "--disable-gconf --disable-qconf"
35
36# Some packages have the version preceeding the .so instead properly
37# versioned .so.<version>, so we need to reorder and repackage.
38SOLIBS = "-${PV}.so"
39FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
40
41BBCLASSEXTEND = "native"