summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-04-27 17:28:12 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-23 17:45:35 +0100
commitcee2ed45a30e9055c301f21e6a136722ae13a5ab (patch)
tree9dba52c40911baf66b56cac4c78483a31c1b9303 /meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb
parentf7c2ec9f8719ee37bdca866c881ca5d853f9aefc (diff)
downloadpoky-cee2ed45a30e9055c301f21e6a136722ae13a5ab.tar.gz
kconfig-frontends: update to 4.10.0.1
Add a couple of patches: - move python script to use Python 3 - fix .pc file installation path (From OE-Core rev: 3469c729a14bbf38bd2e9d7456c0651d8f313546) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb
deleted file mode 100644
index 4ca0e4da3a..0000000000
--- a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Linux kernel style configuration framework for other projects"
5DESCRIPTION = "The kconfig-frontends project aims at centralising \
6the effort of keeping an up-to-date, out-of-tree, packaging of the \
7kconfig infrastructure, ready for use by third-party projects. \
8The kconfig-frontends package provides the kconfig parser, as well as all \
9the frontends"
10HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
11LICENSE = "GPL-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
13SECTION = "devel"
14DEPENDS += "ncurses flex bison gperf-native"
15RDEPENDS_${PN} += "python bash"
16SRC_URI = "git://ymorin.is-a-geek.org/kconfig-frontends"
17
18SRCREV = "75d35b172fc0f7b6620dd659af41f2ce04edc4e6"
19
20S = "${WORKDIR}/git"
21
22inherit autotools pkgconfig
23do_configure_prepend () {
24 mkdir -p ${S}/scripts/.autostuff/m4
25}
26
27do_install_append() {
28 ln -s kconfig-conf ${D}${bindir}/conf
29 ln -s kconfig-mconf ${D}${bindir}/mconf
30}
31
32EXTRA_OECONF += "--disable-gconf --disable-qconf"
33
34# Some packages have the version preceeding the .so instead properly
35# versioned .so.<version>, so we need to reorder and repackage.
36SOLIBS = "-${@d.getVar('PV')[:-2]}.so"
37FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
38
39BBCLASSEXTEND = "native"