summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.10.0.0.bb
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2013-07-08 17:24:29 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-07-10 09:42:05 +0100
commit1d10dc3ec3242d49515c4625bd1c0b6332bff455 (patch)
tree59be5bb62a31ca029ab60c169a810e3f7529fe0a /meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.10.0.0.bb
parent73ebab2dca09a7b8c992aee8e31b8f54ebcd7cec (diff)
downloadpoky-1d10dc3ec3242d49515c4625bd1c0b6332bff455.tar.gz
kconfig-frontends: Update to 3.10
Rename recipe to match upstream tarball name which requires a fix the the SOLIBS numbering (From OE-Core rev: cd749a50eb7dcdb735b5f7bd8b7e15f709e0a38e) Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.10.0.0.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.10.0.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.10.0.0.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.10.0.0.bb
new file mode 100644
index 0000000000..901f115809
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.10.0.0.bb
@@ -0,0 +1,38 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "The kconfig-frontends project aims at centralising \
5the effort of keeping an up-to-date, out-of-tree, packaging of the \
6kconfig infrastructure, ready for use by third-party projects. \
7The kconfig-frontends package provides the kconfig parser, as well as all \
8the frontends"
9HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
12SECTION = "devel"
13DEPENDS += "ncurses flex bison gperf pkgconfig-native"
14SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BP}.tar.xz"
15
16SRC_URI[md5sum] = "1ebf13983eb5b2ce960d131cae290cad"
17SRC_URI[sha256sum] = "442a3794b6dd9427f411ecec25dccab1a4bfcf07fe734f62d40e538afd1f0c8a"
18
19S = "${WORKDIR}/${BPN}-${PV}"
20
21inherit autotools
22do_configure_prepend () {
23 mkdir -p scripts/.autostuff/m4
24}
25
26do_install_append() {
27 ln -s kconfig-conf ${D}${bindir}/conf
28 ln -s kconfig-mconf ${D}${bindir}/mconf
29}
30
31EXTRA_OECONF += "--disable-gconf --disable-qconf"
32
33# Some packages have the version preceeding the .so instead properly
34# versioned .so.<version>, so we need to reorder and repackage.
35SOLIBS = "-${@d.getVar('PV',1)[:-2]}.so"
36FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
37
38BBCLASSEXTEND = "native"