summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.13.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2018-02-02 10:16:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 11:06:28 +0000
commit4cce58051bfda9e9c4d15ad70f15f4f1ee12fc4e (patch)
tree51db3605867aee6f53ede96717f1194cdb83fd4d /meta/recipes-devtools/json-c/json-c_0.13.bb
parenta1027acfd7ea9f0ea9cd751801ac05f01fcd199c (diff)
downloadpoky-4cce58051bfda9e9c4d15ad70f15f4f1ee12fc4e.tar.gz
json-c: update to 0.13
Drop 0001-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch since it had been merged upstream. (From OE-Core rev: 77b46f844c50e3da90f91669baf6ba936ab7af9f) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.13.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.13.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.13.bb b/meta/recipes-devtools/json-c/json-c_0.13.bb
new file mode 100644
index 0000000000..06319de323
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.13.bb
@@ -0,0 +1,31 @@
1SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
8 "
9SRC_URI[md5sum] = "11fc5d90c77375e5fc8401e8b9efbf21"
10SRC_URI[sha256sum] = "0316780be9ad16c42d7c26b015a784fd5df4b0909fef0aba51cfb13e492ac24d"
11
12UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
13# json-c releases page is fetching the list of releases in some weird XML format
14# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
15#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
16RECIPE_UPSTREAM_VERSION = "0.13"
17RECIPE_UPSTREAM_DATE = "Dec 07, 2017"
18CHECK_DATE = "Jan 31, 2018"
19
20RPROVIDES_${PN} = "libjson"
21
22inherit autotools
23
24EXTRA_OECONF = "--enable-rdrand"
25
26do_configure_prepend() {
27 # Clean up autoconf cruft that should not be in the tarball
28 rm -f ${S}/config.status
29}
30
31BBCLASSEXTEND = "native nativesdk"