summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.12.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-04-19 19:31:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-12 08:51:09 +0100
commit7ee0540f5cf55441a4af40fdbb625b6dc20fe44f (patch)
treee4a022763d32e1d309d09a76f7c8874355a40caf /meta/recipes-devtools/json-c/json-c_0.12.1.bb
parent82b555aef24f7ca454a624f5dea2f222b3206663 (diff)
downloadpoky-7ee0540f5cf55441a4af40fdbb625b6dc20fe44f.tar.gz
json-c: Upgrade to 0.12.1 release
Backport fix for gcc7 warning along the way Remove --disable-rpath as this configure doesn't support it anymore [RB]. (From OE-Core rev: ccf630e78aad488da7b80f2981037d3d0559cfad) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.12.1.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.12.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.12.1.bb b/meta/recipes-devtools/json-c/json-c_0.12.1.bb
new file mode 100644
index 0000000000..401cf13205
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.12.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
8 file://0001-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch \
9 "
10SRC_URI[md5sum] = "55f7853f7d8cf664554ce3fa71bf1c7d"
11SRC_URI[sha256sum] = "2a136451a7932d80b7d197b10441e26e39428d67b1443ec43bbba824705e1123"
12
13UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
14# json-c releases page is fetching the list of releases in some weird XML format
15# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
16#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
17RECIPE_UPSTREAM_VERSION = "0.12.1"
18RECIPE_UPSTREAM_DATE = "Jun 07, 2016"
19CHECK_DATE = "Apr 19, 2017"
20
21RPROVIDES_${PN} = "libjson"
22
23inherit autotools
24
25EXTRA_OECONF = "--enable-rdrand"
26
27do_configure_prepend() {
28 # Clean up autoconf cruft that should not be in the tarball
29 rm -f ${S}/config.status
30}
31
32BBCLASSEXTEND = "native nativesdk"