summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.11.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/json-c/json-c_0.11.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.11.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.11.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.11.bb b/meta/recipes-devtools/json-c/json-c_0.11.bb
new file mode 100644
index 0000000000..389e0f9ebf
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.11.bb
@@ -0,0 +1,21 @@
1SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz"
8
9SRC_URI[md5sum] = "aa02367d2f7a830bf1e3376f77881e98"
10SRC_URI[sha256sum] = "28dfc65145dc0d4df1dfe7701ac173c4e5f9347176c8983edbfac9149494448c"
11
12RPROVIDES_${PN} = "libjson"
13
14PARALLEL_MAKE = ""
15
16inherit autotools
17
18do_configure_prepend() {
19 # Clean up autoconf cruft that should not be in the tarball
20 rm -f ${S}/config.status
21}