summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/jquery/jquery_3.6.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-12-28 08:37:15 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-28 23:59:56 +0000
commit7bdc145006e2dc5da5343814116c33b916c3d436 (patch)
treede3a19d1d8b979a8289a92a04aba77cd3a918060 /meta/recipes-devtools/jquery/jquery_3.6.2.bb
parent119f320a46ca2f8ea09baaa1bd5fecbcc67157df (diff)
downloadpoky-7bdc145006e2dc5da5343814116c33b916c3d436.tar.gz
jquery: upgrade 3.6.1 -> 3.6.2
(From OE-Core rev: 4ca35599d102b6c1580bc080a0df645e7e589267) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/jquery/jquery_3.6.2.bb')
-rw-r--r--meta/recipes-devtools/jquery/jquery_3.6.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/jquery/jquery_3.6.2.bb b/meta/recipes-devtools/jquery/jquery_3.6.2.bb
new file mode 100644
index 0000000000..fe6c57d206
--- /dev/null
+++ b/meta/recipes-devtools/jquery/jquery_3.6.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library"
2HOMEPAGE = "https://jquery.com/"
3DESCRIPTION = "${SUMMARY}"
4LICENSE = "MIT"
5SECTION = "devel"
6LIC_FILES_CHKSUM = "file://${S}/${BP}.js;beginline=8;endline=10;md5=9c7c6e9ab275fc1e0d99cb7180ecd14c"
7
8# unpack items to ${S} so the archiver can see them
9#
10SRC_URI = "\
11 https://code.jquery.com/${BP}.js;name=js;subdir=${BP} \
12 https://code.jquery.com/${BP}.min.js;name=min;subdir=${BP} \
13 https://code.jquery.com/${BP}.min.map;name=map;subdir=${BP} \
14 "
15
16SRC_URI[js.sha256sum] = "a649f609466685e49ecacb18c37bcca75fb1cae6f89be7be40ae2c42c92fba8e"
17SRC_URI[min.sha256sum] = "da4ad864a87ffcf71c851b5df87f95cb242867f7b711cae4c6133cc9cc0048f0"
18SRC_URI[map.sha256sum] = "f46902fc1b81c286e51f4eb4812382ee9eedba0e9fc855e4dc3af59e0c57f404"
19
20UPSTREAM_CHECK_REGEX = "jquery-(?P<pver>\d+(\.\d+)+)\.js"
21
22# https://github.com/jquery/jquery/issues/3927
23# There are ways jquery can expose security issues but any issues are in the apps exposing them
24# and there is little we can directly do
25CVE_CHECK_IGNORE += "CVE-2007-2379"
26
27inherit allarch
28
29do_install() {
30 install -d ${D}${datadir}/javascript/${BPN}/
31 install -m 644 ${S}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js
32 install -m 644 ${S}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js
33 install -m 644 ${S}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map
34}
35
36PACKAGES = "${PN}"
37FILES:${PN} = "${datadir}"
38
39BBCLASSEXTEND += "native nativesdk"