summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/intltool/intltool_0.51.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-07-19 12:04:12 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:28:53 +0100
commita61eb1f844814daf525d1db250194ea186c35e71 (patch)
tree034fb5992cc6ff70001b0198b6838eb6bbab8eb0 /meta/recipes-devtools/intltool/intltool_0.51.0.bb
parentae39c3a0f687b6e23d2726defa8287eacb6f8a79 (diff)
downloadpoky-a61eb1f844814daf525d1db250194ea186c35e71.tar.gz
intltool: remove broken XML::Parser detection
intltool.m4 has a chunk of code that runs during configure which probes for a perl binary and verifies that it has the XML::Parser module. However in builds using intltool-native the perl binary that it finds is likely to not be the one that the intltool scripts will be using as the scripts hardcode nativeperl yet the m4 fragment searches for "perl" in $PATH. If the host perl doesn't have XML::Parser the configure will fail, despite the fact that the scripts will work. Solve this by taking an old patch from the upstream bug system to simply remove the check in intltool.m4 as it's generally useless, and remove existing patches that almost but not quite solved this issue. (From OE-Core rev: 9900000d404b09a701d5368d529eb515e054e3f0) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/intltool/intltool_0.51.0.bb')
-rw-r--r--meta/recipes-devtools/intltool/intltool_0.51.0.bb21
1 files changed, 8 insertions, 13 deletions
diff --git a/meta/recipes-devtools/intltool/intltool_0.51.0.bb b/meta/recipes-devtools/intltool/intltool_0.51.0.bb
index 0a610a31f9..a7ea3b727d 100644
--- a/meta/recipes-devtools/intltool/intltool_0.51.0.bb
+++ b/meta/recipes-devtools/intltool/intltool_0.51.0.bb
@@ -6,23 +6,23 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6SRC_URI = "http://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz \ 6SRC_URI = "http://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz \
7 file://intltool-nowarn.patch \ 7 file://intltool-nowarn.patch \
8 file://perl-522-deprecations.patch \ 8 file://perl-522-deprecations.patch \
9 ${NATIVEPATCHES} \ 9 file://remove-perl-check.patch \
10 file://noperlcheck.patch \
10 " 11 "
11SRC_URI[md5sum] = "12e517cac2b57a0121cda351570f1e63" 12SRC_URI[md5sum] = "12e517cac2b57a0121cda351570f1e63"
12SRC_URI[sha256sum] = "67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd" 13SRC_URI[sha256sum] = "67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd"
13 14
14# All of the intltool scripts have the correct paths to perl already
15# embedded into them and can find perl fine, so we add the remove xml-check
16# in the intltool.m4 via the remove-xml-check.patch
17NATIVEPATCHES = "file://noperlcheck.patch \
18 file://remove-xml-check.patch"
19NATIVEPATCHES_class-native = "file://use-nativeperl.patch"
20
21UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/" 15UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/"
22 16
23DEPENDS = "libxml-parser-perl-native" 17DEPENDS = "libxml-parser-perl-native"
24RDEPENDS_${PN} = "gettext-dev libxml-parser-perl" 18RDEPENDS_${PN} = "gettext-dev libxml-parser-perl"
25DEPENDS_class-native = "libxml-parser-perl-native" 19DEPENDS_class-native = "libxml-parser-perl-native"
20
21inherit autotools pkgconfig perlnative
22
23export PERL = "${bindir}/env perl"
24PERL_class-native = "/usr/bin/env nativeperl"
25
26# gettext is assumed to exist on the host 26# gettext is assumed to exist on the host
27RDEPENDS_${PN}_class-native = "libxml-parser-perl-native" 27RDEPENDS_${PN}_class-native = "libxml-parser-perl-native"
28RRECOMMENDS_${PN} = "perl-modules" 28RRECOMMENDS_${PN} = "perl-modules"
@@ -33,9 +33,4 @@ FILES_${PN} += "${datadir}/aclocal"
33 33
34INSANE_SKIP_${PN} += "dev-deps" 34INSANE_SKIP_${PN} += "dev-deps"
35 35
36inherit autotools pkgconfig perlnative
37
38export PERL = "${bindir}/env perl"
39PERL_class-native = "/usr/bin/env nativeperl"
40
41BBCLASSEXTEND = "native" 36BBCLASSEXTEND = "native"