diff options
author | Liping Ke <liping.ke@intel.com> | 2011-01-03 23:21:40 -0800 |
---|---|---|
committer | Saul Wold <sgw@linux.intel.com> | 2011-01-12 00:55:49 -0800 |
commit | 514e59c780ac24439ae0839fab311d843841bf68 (patch) | |
tree | 3130a2992cc9428db0440427dc9df74fd06662c9 /meta/recipes-devtools/installer/adt-installer_1.0.bb | |
parent | 03072100f112b9690c1a99d1c406c098a9005a84 (diff) | |
download | poky-514e59c780ac24439ae0839fab311d843841bf68.tar.gz |
adt-intaller feature implementation, including the bitbake recipe file for creating the intaller tar file under /tmp/deploy/sdk, and the adt-installer script files and config files, set the reference to adt repo entry empty before it's setup
Signed-off-by: Jessica Zhang <jessica.zhang@intel.com>
Diffstat (limited to 'meta/recipes-devtools/installer/adt-installer_1.0.bb')
-rw-r--r-- | meta/recipes-devtools/installer/adt-installer_1.0.bb | 84 |
1 files changed, 84 insertions, 0 deletions
diff --git a/meta/recipes-devtools/installer/adt-installer_1.0.bb b/meta/recipes-devtools/installer/adt-installer_1.0.bb new file mode 100644 index 0000000000..226e375c3f --- /dev/null +++ b/meta/recipes-devtools/installer/adt-installer_1.0.bb | |||
@@ -0,0 +1,84 @@ | |||
1 | # Yocto ADT Installer bb file | ||
2 | # | ||
3 | # Copyright 2010-2011 by Intel Corp. | ||
4 | # | ||
5 | # Permission is hereby granted, free of charge, to any person obtaining a copy | ||
6 | # of this software and associated documentation files (the "Software"), to deal | ||
7 | # in the Software without restriction, including without limitation the rights | ||
8 | # to use, copy, modify, merge, publish, distribute, sublicense, and/or sell | ||
9 | # copies of the Software, and to permit persons to whom the Software is | ||
10 | # furnished to do so, subject to the following conditions: | ||
11 | |||
12 | # The above copyright notice and this permission notice shall be included in | ||
13 | # all copies or substantial portions of the Software. | ||
14 | |||
15 | # THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR | ||
16 | # IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, | ||
17 | # FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE | ||
18 | # AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER | ||
19 | # LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, | ||
20 | # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN | ||
21 | # THE SOFTWARE. | ||
22 | |||
23 | |||
24 | DESCRIPTION = "Meta package for creating sdk installer tarball" | ||
25 | LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ | ||
26 | file://${POKYBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | ||
27 | LICENSE = "MIT" | ||
28 | |||
29 | ALLOW_EMPTY = "1" | ||
30 | |||
31 | PACKAGES = "" | ||
32 | PACKAGE_ARCH = "all" | ||
33 | |||
34 | PR = "r0" | ||
35 | |||
36 | ADT_DEPLOY = "${TMPDIR}/deploy/sdk/" | ||
37 | ADT_DIR = "${WORKDIR}/adt-installer/" | ||
38 | YOCTOADT_VERSION = "${SDK_VERSION}" | ||
39 | |||
40 | inherit deploy | ||
41 | |||
42 | SRC_URI = "http://opkg.googlecode.com/files/opkg-0.1.8.tar.gz \ | ||
43 | file://adt_installer \ | ||
44 | file://scripts/adt_installer_internal \ | ||
45 | file://scripts/util \ | ||
46 | file://scripts/data_define \ | ||
47 | file://scripts/extract_rootfs \ | ||
48 | file://adt_installer.conf \ | ||
49 | file://opkg/conf/opkg-sdk-x86_64.conf \ | ||
50 | file://opkg/conf/opkg-sdk-i586.conf \ | ||
51 | " | ||
52 | SRC_URI[md5sum] = "c714ce0e4863bf1315e3b6913ffe3299" | ||
53 | SRC_URI[sha256sum] = "ff94bf30bd662d49c4b5057e3a0818d062731adaa555d59abd677ec32a3c1c60" | ||
54 | |||
55 | fakeroot do_deploy () { | ||
56 | cd ${WORKDIR} | ||
57 | mkdir -p ${ADT_DEPLOY} | ||
58 | rm -f ${ADT_DEPLOY}/adt-installer.tar.bz2 | ||
59 | rm -rf ${ADT_DIR} | ||
60 | mkdir -p ${ADT_DIR}/opkg/build | ||
61 | cp -r opkg ${ADT_DIR}/ | ||
62 | cp -r opkg-0.1.8 ${ADT_DIR}/opkg/build/ | ||
63 | cp -r scripts ${ADT_DIR}/ | ||
64 | cp adt_installer ${ADT_DIR} | ||
65 | cp adt_installer.conf ${ADT_DIR} | ||
66 | echo 'YOCTOADT_VERSION=${SDK_VERSION}' > ${ADT_DIR}/temp.conf | ||
67 | cat ${ADT_DIR}/adt_installer.conf >> ${ADT_DIR}/temp.conf | ||
68 | mv ${ADT_DIR}/temp.conf ${ADT_DIR}/adt_installer.conf | ||
69 | tar cfj adt_installer.tar.bz2 adt-installer | ||
70 | cp ${WORKDIR}/adt_installer.tar.bz2 ${ADT_DEPLOY} | ||
71 | } | ||
72 | |||
73 | do_patch[noexec] = "1" | ||
74 | do_install[noexec] = "1" | ||
75 | do_configure[noexec] = "1" | ||
76 | do_compile[noexec] = "1" | ||
77 | do_package[noexec] = "1" | ||
78 | do_package_write[noexec] = "1" | ||
79 | do_package_write_ipk[noexec] = "1" | ||
80 | do_package_write_rpm[noexec] = "1" | ||
81 | do_package_write_deb[noexec] = "1" | ||
82 | do_poplulate_sysroot[noexec] = "1" | ||
83 | |||
84 | addtask deploy before do_populate_sysroot after do_unpack | ||