summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/installer/adt-installer_1.0.bb
diff options
context:
space:
mode:
authorLiping Ke <liping.ke@intel.com>2011-03-10 17:27:55 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-03-10 18:14:27 -0800
commitf776bc667eb99bf554f433d75a381ebbb1ddb618 (patch)
treee97a6073f0f1ee02e9aa4da5438862509e934c15 /meta/recipes-devtools/installer/adt-installer_1.0.bb
parent30dbfde8ebcb761120eb1ab1d213e850cac966fd (diff)
downloadpoky-f776bc667eb99bf554f433d75a381ebbb1ddb618.tar.gz
Disable wget server side cache
We found some proxy server has wrong cache for long http file name. It will cause fetching wrong ipk files from adt repo. To avoid this, we use wget options --no-cache to disable all server side cache. It will make the fetch speed slower, yet correct always. (From OE-Core rev: 2e9e8af197671ae06de1bdc9201765b160869d60) Signed-off-by: Liping Ke <liping.ke@intel.com> Signed-off-by: Lianhao Lu <lianhao.lu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/installer/adt-installer_1.0.bb')
-rw-r--r--meta/recipes-devtools/installer/adt-installer_1.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/installer/adt-installer_1.0.bb b/meta/recipes-devtools/installer/adt-installer_1.0.bb
index 50290f9ffd..ff7afe6623 100644
--- a/meta/recipes-devtools/installer/adt-installer_1.0.bb
+++ b/meta/recipes-devtools/installer/adt-installer_1.0.bb
@@ -36,11 +36,13 @@ PR = "r0"
36ADT_DEPLOY = "${TMPDIR}/deploy/sdk/" 36ADT_DEPLOY = "${TMPDIR}/deploy/sdk/"
37ADT_DIR = "${WORKDIR}/adt-installer/" 37ADT_DIR = "${WORKDIR}/adt-installer/"
38YOCTOADT_VERSION = "${SDK_VERSION}" 38YOCTOADT_VERSION = "${SDK_VERSION}"
39S = "${WORKDIR}/trunk"
39 40
40inherit deploy 41inherit deploy
41 42
42PV = "0.1.8+svnr${SRCPV}" 43PV = "0.1.8+svnr${SRCPV}"
43SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \ 44SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
45 file://wget_cache.patch \
44 file://adt_installer \ 46 file://adt_installer \
45 file://scripts/adt_installer_internal \ 47 file://scripts/adt_installer_internal \
46 file://scripts/util \ 48 file://scripts/util \
@@ -70,7 +72,6 @@ fakeroot do_deploy () {
70 cp ${WORKDIR}/adt_installer.tar.bz2 ${ADT_DEPLOY} 72 cp ${WORKDIR}/adt_installer.tar.bz2 ${ADT_DEPLOY}
71} 73}
72 74
73do_patch[noexec] = "1"
74do_install[noexec] = "1" 75do_install[noexec] = "1"
75do_configure[noexec] = "1" 76do_configure[noexec] = "1"
76do_compile[noexec] = "1" 77do_compile[noexec] = "1"