summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/icecc-toolchain/nativesdk-icecc-toolchain_0.1.bb
diff options
context:
space:
mode:
authorJoshua Watt <jpewhacker@gmail.com>2018-02-12 10:52:08 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-16 18:05:38 +0000
commitc129cbe1b88d5d497a55af3c66d5541133484a09 (patch)
treeaace59193564a0e48929b0881b492434ea595bca /meta/recipes-devtools/icecc-toolchain/nativesdk-icecc-toolchain_0.1.bb
parentcf85c5a490b7044f2a5291c7df646248e81770f7 (diff)
downloadpoky-c129cbe1b88d5d497a55af3c66d5541133484a09.tar.gz
icecc-toolchain: Add SDK icecream setup
Icecream can now be optionally included in the generated SDK by including nativesdk-icecc-toolchain to TOOLCHAIN_HOST_TASK. When the SDK is installed a post-relocation script will check if icecc exists and if so will generate the toolchain environment. (From OE-Core rev: 7e524096879e821256812633ce37cda4b85b3073) Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/icecc-toolchain/nativesdk-icecc-toolchain_0.1.bb')
-rw-r--r--meta/recipes-devtools/icecc-toolchain/nativesdk-icecc-toolchain_0.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/icecc-toolchain/nativesdk-icecc-toolchain_0.1.bb b/meta/recipes-devtools/icecc-toolchain/nativesdk-icecc-toolchain_0.1.bb
new file mode 100644
index 0000000000..91958d7fbc
--- /dev/null
+++ b/meta/recipes-devtools/icecc-toolchain/nativesdk-icecc-toolchain_0.1.bb
@@ -0,0 +1,38 @@
1# Copyright (c) 2018 Joshua Watt, Garmin International,Inc.
2# Released under the MIT license (see COPYING.MIT for the terms)
3SUMMARY = "Generates Icecream toolchain for SDK"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${WORKDIR}/icecc-env.sh;beginline=2;endline=20;md5=aafdb7bc2aa7ac5d039fda0c8733983c"
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "\
10 file://icecc-env.sh \
11 file://icecc-setup.sh \
12 "
13
14inherit nativesdk
15
16ENV_NAME="${DISTRO}-${TCLIBC}-${SDK_ARCH}-${TUNE_PKGARCH}-${DISTRO_VERSION}.tar.gz"
17
18do_compile() {
19}
20
21do_install() {
22 install -d ${D}${SDKPATHNATIVE}${datadir}/icecream/bin
23
24 install -d ${D}${SDKPATHNATIVE}/environment-setup.d/
25 install -m 0644 ${WORKDIR}/icecc-env.sh ${D}${SDKPATHNATIVE}/environment-setup.d/
26 sed -i ${D}${SDKPATHNATIVE}/environment-setup.d/icecc-env.sh \
27 -e "s,@TOOLCHAIN_ENV@,${ENV_NAME},g"
28
29 install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d/
30 install -m 0755 ${WORKDIR}/icecc-setup.sh ${D}${SDKPATHNATIVE}/post-relocate-setup.d/
31 sed -i ${D}${SDKPATHNATIVE}/post-relocate-setup.d/icecc-setup.sh \
32 -e "s,@TOOLCHAIN_ENV@,${ENV_NAME},g"
33}
34
35PACKAGES = "${PN}"
36FILES_${PN} = "${SDKPATHNATIVE}"
37RDEPENDS_${PN} += "nativesdk-icecc-create-env"
38