summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-01-31 11:05:11 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 11:06:28 +0000
commit95fbee5af37a388fd9fdb23a16b90cc43b875b8e (patch)
tree6704a3aa8e1ced497486aa47474f417c42897007 /meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb
parent7aa9be36dbb911d860990030188bea8e29a8375d (diff)
downloadpoky-95fbee5af37a388fd9fdb23a16b90cc43b875b8e.tar.gz
i2c-tools: rewrite packaging
For unknowable reasons this recipe inherits autotools-brokensep despite not in fact using autotools. Remove the inherit, add a do_install() that calls the makefile directly. Extend EXTRA_OEMAKE to pass bindir/sbindir/incdir/libdir/mandir so the files are all packaged in the correct location (and remove the now redundant sed of Makefile). Pass EXTRA=eeprog to EXTRA_OEMAKE to build eeprog, and remove the now redundant edit of Makefile. Backport a patch from upstream to remove linux/i2c-dev.h instead of installing it with a different name (which nobody will be using). (From OE-Core rev: a5d5d66c30378c35900c46dac4e4824a10521477) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb')
-rw-r--r--meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb17
1 files changed, 7 insertions, 10 deletions
diff --git a/meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb b/meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb
index e936fd759b..01ac47f611 100644
--- a/meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb
+++ b/meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb
@@ -8,22 +8,19 @@ SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/${BP}.tar.gz \
8 file://0001-lib-Module.mk-Add-missing-dependencies.patch \ 8 file://0001-lib-Module.mk-Add-missing-dependencies.patch \
9 file://0001-tools-Module.mk-Add-missing-dependencies.patch \ 9 file://0001-tools-Module.mk-Add-missing-dependencies.patch \
10 file://0001-i2c-tools-eeprog-Module.mk-Add-missing-dependency.patch \ 10 file://0001-i2c-tools-eeprog-Module.mk-Add-missing-dependency.patch \
11 file://remove-i2c-dev.patch \
11" 12"
12 13
13SRC_URI[md5sum] = "d92a288d70f306d3895e3a7e9c14c9aa" 14SRC_URI[md5sum] = "d92a288d70f306d3895e3a7e9c14c9aa"
14SRC_URI[sha256sum] = "5b60daf6f011de0acb61de57dba62f2054bb39f19961d67e0c91610f071ca403" 15SRC_URI[sha256sum] = "5b60daf6f011de0acb61de57dba62f2054bb39f19961d67e0c91610f071ca403"
15 16
16inherit autotools-brokensep 17EXTRA_OEMAKE = "bindir=${bindir} sbindir=${sbindir} \
18 incdir=${includedir} libdir=${libdir} \
19 mandir=${mandir} \
20 EXTRA=eeprog"
17 21
18do_compile_prepend() { 22do_install() {
19 sed -i 's#/usr/local#/usr#' ${S}/Makefile 23 oe_runmake 'DESTDIR=${D}' install
20 echo "include eeprog/Module.mk" >> ${S}/Makefile
21}
22
23do_install_append() {
24 install -d ${D}${includedir}/linux
25 install -m 0644 include/linux/i2c-dev.h ${D}${includedir}/linux/i2c-dev-user.h
26 rm -f ${D}${includedir}/linux/i2c-dev.h
27} 24}
28 25
29PACKAGES =+ "${PN}-misc" 26PACKAGES =+ "${PN}-misc"