summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@enea.com>2014-07-30 10:47:12 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-02 09:26:14 +0100
commit593f00d3f13150db54e006ef1b1deaae31f914a4 (patch)
treec7535c50dd1a1a588279225b6f833133aa5c04d9 /meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
parent704dd12151adbab5907b6fe65384cff860b6028d (diff)
downloadpoky-593f00d3f13150db54e006ef1b1deaae31f914a4.tar.gz
i2c-tools: Uprev to 3.1.1
1. Updated the SRC_URI to http://dl.lm-sensors.org/i2c-tools/ 2. Corrected the License to GPLv2+ as the "COPYING" file include these statements: "This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version." (From OE-Core rev: d5fe5a93d310966d5389600c9e102f894772325b) Signed-off-by: Maxin B. John <maxin.john@enea.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb')
-rw-r--r--meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb b/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
new file mode 100644
index 0000000000..460541440b
--- /dev/null
+++ b/meta/recipes-devtools/i2c-tools/i2c-tools_3.1.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Set of i2c tools for linux"
2SECTION = "base"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6RDEPENDS_${PN} += "perl"
7
8SRC_URI = "http://dl.lm-sensors.org/i2c-tools/releases/${BP}.tar.bz2 \
9 file://Module.mk \
10"
11SRC_URI[md5sum] = "0fdbff53ebd0b8d9249256d6c56480b1"
12SRC_URI[sha256sum] = "14d4d7d60d1c12e43f2befe239c682a5c44c27682f153d4b58c1e392d2db1700"
13
14inherit autotools-brokensep
15
16do_compile_prepend() {
17 cp ${WORKDIR}/Module.mk ${S}/eepromer/
18 sed -i 's#/usr/local#/usr#' ${S}/Makefile
19 echo "include eepromer/Module.mk" >> ${S}/Makefile
20}
21
22do_install_append() {
23 install -d ${D}${includedir}/linux
24 install -m 0644 include/linux/i2c-dev.h ${D}${includedir}/linux/i2c-dev-user.h
25 rm -f ${D}${includedir}/linux/i2c-dev.h
26}