summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile/guile_2.0.9.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
committerTudor Florea <tudor.florea@enea.com>2014-10-16 03:05:19 +0200
commitc527fd1f14c27855a37f2e8ac5346ce8d940ced2 (patch)
treebb002c1fdf011c41dbd2f0927bed23ecb5f83c97 /meta/recipes-devtools/guile/guile_2.0.9.bb
downloadpoky-daisy-140929.tar.gz
initial commit for Enea Linux 4.0-140929daisy-140929
Migrated from the internal git server on the daisy-enea-point-release branch Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/guile/guile_2.0.9.bb')
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.9.bb104
1 files changed, 104 insertions, 0 deletions
diff --git a/meta/recipes-devtools/guile/guile_2.0.9.bb b/meta/recipes-devtools/guile/guile_2.0.9.bb
new file mode 100644
index 0000000000..60318e73cf
--- /dev/null
+++ b/meta/recipes-devtools/guile/guile_2.0.9.bb
@@ -0,0 +1,104 @@
1SUMMARY = "Guile is the GNU Ubiquitous Intelligent Language for Extensions"
2DESCRIPTION = "Guile is the GNU Ubiquitous Intelligent Language for Extensions,\
3 the official extension language for the GNU operating system.\
4 Guile is a library designed to help programmers create flexible applications.\
5 Using Guile in an application allows the application's functionality to be\
6 extended by users or other programmers with plug-ins, modules, or scripts.\
7 Guile provides what might be described as 'practical software freedom,'\
8 making it possible for users to customize an application to meet their\
9 needs without digging into the application's internals."
10
11HOMEPAGE = "http://www.gnu.org/software/guile/"
12SECTION = "devel"
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15
16SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.xz \
17 file://debian/0002-Mark-Unused-modules-are-removed-gc-test-as-unresolve.patch \
18 file://debian/0003-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch \
19 file://opensuse/guile-64bit.patch \
20 file://guile_2.0.6_fix_sed_error.patch \
21 file://arm_endianness.patch \
22 file://guile_2.0.9_fix_noreturn.patch \
23 "
24
25# file://debian/0001-Change-guile-to-guile-X.Y-for-info-pages.patch
26# file://opensuse/guile-turn-off-gc-test.patch
27
28SRC_URI[md5sum] = "a69b575d4a633bdd9118f3a4a1e97766"
29SRC_URI[sha256sum] = "f70a38c8d9751f442679bfe61852bba8545af4d4355d037630997c2f37f2895b"
30
31
32inherit autotools gettext
33BBCLASSEXTEND = "native"
34
35DEPENDS = "libunistring bdwgc gmp libtool libffi"
36# add guile-native only to the target recipe's DEPENDS
37DEPENDS_append_class-target = " guile-native libatomics-ops"
38
39RDEPENDS_${PN}_append_libc-glibc_class-target = "glibc-gconv-iso8859-1"
40
41EXTRA_OECONF += "${@['--without-libltdl-prefix --without-libgmp-prefix --without-libreadline-prefix', ''][bb.data.inherits_class('native',d)]}"
42
43do_configure_prepend() {
44 mkdir -p po
45}
46
47export GUILE_FOR_BUILD="${BUILD_SYS}-guile"
48
49do_compile_append() {
50 # just for target recipe
51 if [ "${PN}" = "guile" ]
52 then
53 sed -i -e s:${STAGING_DIR_TARGET}::g \
54 -e s:/${TARGET_SYS}::g \
55 -e s:-L/usr/lib::g \
56 -e s:-isystem/usr/include::g \
57 -e s:,/usr/lib:,\$\{libdir\}:g \
58 meta/guile-2.0.pc
59 fi
60}
61
62do_install_append_class-native() {
63 install -m 0755 ${D}${bindir}/guile ${D}${bindir}/${HOST_SYS}-guile
64
65 create_wrapper ${D}/${bindir}/guile \
66 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
67 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
68 create_wrapper ${D}${bindir}/${HOST_SYS}-guile \
69 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
70 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
71}
72
73SYSROOT_PREPROCESS_FUNCS = "guile_cross_config"
74
75guile_cross_config() {
76 # this is only for target recipe
77 if [ "${PN}" = "guile" ]
78 then
79 # Create guile-config returning target values instead of native values
80 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}
81 echo '#!'`which ${BUILD_SYS}-guile`$' \\\n--no-auto-compile -e main -s\n!#\n(define %guile-build-info '\'\( \
82 > guile-config.cross
83 sed -n -e 's:^[ \t]*{[ \t]*": (:' \
84 -e 's:",[ \t]*": . ":' \
85 -e 's:" *}, *\\:"):' \
86 -e 's:^.*cachedir.*$::' \
87 -e '/^ (/p' \
88 < libguile/libpath.h >> guile-config.cross
89 echo '))' >> guile-config.cross
90 cat meta/guile-config >> guile-config.cross
91 install guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config
92 fi
93}
94
95# Guile needs the compiled files to be newer than the source, and it won't
96# auto-compile into the prefix even if it can write there, so touch them here as
97# sysroot is managed.
98SSTATEPOSTINSTFUNCS += "guile_sstate_postinst"
99guile_sstate_postinst() {
100 if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
101 then
102 find ${STAGING_DIR_TARGET}/${libdir}/guile/2.0/ccache -type f | xargs touch
103 fi
104}