diff options
author | Chong Lu <Chong.Lu@windriver.com> | 2014-05-20 09:28:26 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-05-21 19:50:21 +0100 |
commit | 894df445fa71a170397c6e0b4960a89ef20a4230 (patch) | |
tree | 33dad3b34d2a12b98bf66268fadc98229bea2e94 /meta/recipes-devtools/guile/guile_2.0.11.bb | |
parent | da3a742587514573d1bb3b4bf88fd0ca01370f31 (diff) | |
download | poky-894df445fa71a170397c6e0b4960a89ef20a4230.tar.gz |
guile: Update to 2.0.11 version
Upgrade guile to 2.0.11 version and remove unneeded patch since
it's included in new version.
(From OE-Core rev: f1727bb18f35ff01e53d3d442a6ff3c613639fa6)
Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/guile/guile_2.0.11.bb')
-rw-r--r-- | meta/recipes-devtools/guile/guile_2.0.11.bb | 103 |
1 files changed, 103 insertions, 0 deletions
diff --git a/meta/recipes-devtools/guile/guile_2.0.11.bb b/meta/recipes-devtools/guile/guile_2.0.11.bb new file mode 100644 index 0000000000..c597111826 --- /dev/null +++ b/meta/recipes-devtools/guile/guile_2.0.11.bb | |||
@@ -0,0 +1,103 @@ | |||
1 | SUMMARY = "Guile is the GNU Ubiquitous Intelligent Language for Extensions" | ||
2 | DESCRIPTION = "Guile is the GNU Ubiquitous Intelligent Language for Extensions,\ | ||
3 | the official extension language for the GNU operating system.\ | ||
4 | Guile is a library designed to help programmers create flexible applications.\ | ||
5 | Using Guile in an application allows the application's functionality to be\ | ||
6 | extended by users or other programmers with plug-ins, modules, or scripts.\ | ||
7 | Guile provides what might be described as 'practical software freedom,'\ | ||
8 | making it possible for users to customize an application to meet their\ | ||
9 | needs without digging into the application's internals." | ||
10 | |||
11 | HOMEPAGE = "http://www.gnu.org/software/guile/" | ||
12 | SECTION = "devel" | ||
13 | LICENSE = "GPLv3" | ||
14 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
15 | |||
16 | SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.xz \ | ||
17 | file://debian/0002-Mark-Unused-modules-are-removed-gc-test-as-unresolve.patch \ | ||
18 | file://debian/0003-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch \ | ||
19 | file://opensuse/guile-64bit.patch \ | ||
20 | file://guile_2.0.6_fix_sed_error.patch \ | ||
21 | file://arm_endianness.patch \ | ||
22 | " | ||
23 | |||
24 | # file://debian/0001-Change-guile-to-guile-X.Y-for-info-pages.patch | ||
25 | # file://opensuse/guile-turn-off-gc-test.patch | ||
26 | |||
27 | SRC_URI[md5sum] = "03f1bce1a4983076d955003472306a13" | ||
28 | SRC_URI[sha256sum] = "aed0a4a6db4e310cbdfeb3613fa6f86fddc91ef624c1e3f8937a6304c69103e2" | ||
29 | |||
30 | |||
31 | inherit autotools gettext texinfo | ||
32 | BBCLASSEXTEND = "native" | ||
33 | |||
34 | DEPENDS = "libunistring bdwgc gmp libtool libffi" | ||
35 | # add guile-native only to the target recipe's DEPENDS | ||
36 | DEPENDS_append_class-target = " guile-native libatomics-ops" | ||
37 | |||
38 | RDEPENDS_${PN}_append_libc-glibc_class-target = "glibc-gconv-iso8859-1" | ||
39 | |||
40 | EXTRA_OECONF += "${@['--without-libltdl-prefix --without-libgmp-prefix --without-libreadline-prefix', ''][bb.data.inherits_class('native',d)]}" | ||
41 | |||
42 | do_configure_prepend() { | ||
43 | mkdir -p po | ||
44 | } | ||
45 | |||
46 | export GUILE_FOR_BUILD="${BUILD_SYS}-guile" | ||
47 | |||
48 | do_compile_append() { | ||
49 | # just for target recipe | ||
50 | if [ "${PN}" = "guile" ] | ||
51 | then | ||
52 | sed -i -e s:${STAGING_DIR_TARGET}::g \ | ||
53 | -e s:/${TARGET_SYS}::g \ | ||
54 | -e s:-L/usr/lib::g \ | ||
55 | -e s:-isystem/usr/include::g \ | ||
56 | -e s:,/usr/lib:,\$\{libdir\}:g \ | ||
57 | meta/guile-2.0.pc | ||
58 | fi | ||
59 | } | ||
60 | |||
61 | do_install_append_class-native() { | ||
62 | install -m 0755 ${D}${bindir}/guile ${D}${bindir}/${HOST_SYS}-guile | ||
63 | |||
64 | create_wrapper ${D}/${bindir}/guile \ | ||
65 | GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \ | ||
66 | GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache | ||
67 | create_wrapper ${D}${bindir}/${HOST_SYS}-guile \ | ||
68 | GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \ | ||
69 | GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache | ||
70 | } | ||
71 | |||
72 | SYSROOT_PREPROCESS_FUNCS = "guile_cross_config" | ||
73 | |||
74 | guile_cross_config() { | ||
75 | # this is only for target recipe | ||
76 | if [ "${PN}" = "guile" ] | ||
77 | then | ||
78 | # Create guile-config returning target values instead of native values | ||
79 | install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS} | ||
80 | echo '#!'`which ${BUILD_SYS}-guile`$' \\\n--no-auto-compile -e main -s\n!#\n(define %guile-build-info '\'\( \ | ||
81 | > guile-config.cross | ||
82 | sed -n -e 's:^[ \t]*{[ \t]*": (:' \ | ||
83 | -e 's:",[ \t]*": . ":' \ | ||
84 | -e 's:" *}, *\\:"):' \ | ||
85 | -e 's:^.*cachedir.*$::' \ | ||
86 | -e '/^ (/p' \ | ||
87 | < libguile/libpath.h >> guile-config.cross | ||
88 | echo '))' >> guile-config.cross | ||
89 | cat meta/guile-config >> guile-config.cross | ||
90 | install guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config | ||
91 | fi | ||
92 | } | ||
93 | |||
94 | # Guile needs the compiled files to be newer than the source, and it won't | ||
95 | # auto-compile into the prefix even if it can write there, so touch them here as | ||
96 | # sysroot is managed. | ||
97 | SSTATEPOSTINSTFUNCS += "guile_sstate_postinst" | ||
98 | guile_sstate_postinst() { | ||
99 | if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ] | ||
100 | then | ||
101 | find ${STAGING_DIR_TARGET}/${libdir}/guile/2.0/ccache -type f | xargs touch | ||
102 | fi | ||
103 | } | ||