summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.9.bb
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-08-09 11:44:46 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-15 09:44:33 +0100
commitb0206bd90be327c0b2abfeae189e0cda4804a53e (patch)
tree0f5459a7a73cda6e25a792a48d9012d28dcc9997 /meta/recipes-devtools/go/go_1.9.bb
parent63a4ff7cf5f7d1671ab85800bc2212dd9cd9748d (diff)
downloadpoky-b0206bd90be327c0b2abfeae189e0cda4804a53e.tar.gz
go(-dep): add INSANE_SKIP for textrel
* I'm not using go or go-dep, so I'm not going to fix it proplerly, it was just bothering me in world builds * this is reproducible only with ptest in DISTRO_FEATUREs (for aarch64 issue) and included security_flags.inc, more specifically with the PIE flags, so alternative work around is: SECURITY_CFLAGS_pn-go = "${SECURITY_NOPIE_CFLAGS}" SECURITY_CFLAGS_pn-go-dep = "${SECURITY_NOPIE_CFLAGS}" (From OE-Core rev: b689c72ad2dc84b8bb55ecbf72d95701707b9bb3) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.9.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.9.bb b/meta/recipes-devtools/go/go_1.9.bb
index ec5a314e7d..7da7897cf5 100644
--- a/meta/recipes-devtools/go/go_1.9.bb
+++ b/meta/recipes-devtools/go/go_1.9.bb
@@ -15,3 +15,10 @@ do_compile() {
15 ./make.bash 15 ./make.bash
16 cd ${B} 16 cd ${B}
17} 17}
18
19# for aarch64 ends with textrel in ${PN}
20# http://errors.yoctoproject.org/Errors/Details/185634/
21# ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/bin/go' has relocations in .text
22# ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/pkg/tool/linux_arm64/trace' has relocations in .text
23# ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/pkg/tool/linux_arm64/pprof' has relocations in .text [textrel]
24INSANE_SKIP_${PN} += "textrel"