summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.9.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-12-19 14:42:31 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-08 20:14:44 +0000
commita8bccfa9a5bd4f68b2d96236f012bff61cca926b (patch)
tree53987b3ec9e5f05c02e7d9d873aa7f4833e1bb56 /meta/recipes-devtools/go/go_1.9.bb
parent3fc361f5f088c4756cdab423c98bd390daf4265b (diff)
downloadpoky-a8bccfa9a5bd4f68b2d96236f012bff61cca926b.tar.gz
go 1.9/1.11: fix textrel qa warning for non mips arch
While building go itself, the go build system does not support to set `-buildmode=pie' from environment. Add GOBUILDMODE to support it which make PIE executables the default build mode, as PIE executables are required as of Yocto But mips doesn't support -buildmode=pie, so skip the QA checking for mips and its variants (From OE-Core rev: 7a8c5d29f70574043d695bc60da16c823d12a83e) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.9.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/meta/recipes-devtools/go/go_1.9.bb b/meta/recipes-devtools/go/go_1.9.bb
index 7da7897cf5..c23ea0c1ae 100644
--- a/meta/recipes-devtools/go/go_1.9.bb
+++ b/meta/recipes-devtools/go/go_1.9.bb
@@ -5,6 +5,7 @@ export GO_TARGET_INSTALL = "cmd"
5export GO_FLAGS = "-a" 5export GO_FLAGS = "-a"
6export CC_FOR_TARGET = "${CC}" 6export CC_FOR_TARGET = "${CC}"
7export CXX_FOR_TARGET = "${CXX}" 7export CXX_FOR_TARGET = "${CXX}"
8export GOBUILDMODE=""
8 9
9do_compile() { 10do_compile() {
10 export GOBIN="${B}/bin" 11 export GOBIN="${B}/bin"
@@ -16,9 +17,12 @@ do_compile() {
16 cd ${B} 17 cd ${B}
17} 18}
18 19
19# for aarch64 ends with textrel in ${PN} 20# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
20# http://errors.yoctoproject.org/Errors/Details/185634/ 21# doesn't support -buildmode=pie, so skip the QA checking for mips and its
21# ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/bin/go' has relocations in .text 22# variants.
22# ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/pkg/tool/linux_arm64/trace' has relocations in .text 23python() {
23# ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/pkg/tool/linux_arm64/pprof' has relocations in .text [textrel] 24 if 'mips' in d.getVar('TARGET_ARCH'):
24INSANE_SKIP_${PN} += "textrel" 25 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
26 else:
27 d.setVar('GOBUILDMODE', 'pie')
28}