summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.17.7.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-02-14 22:27:26 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-18 11:47:26 +0000
commit3858855d0d9cdabc605eab76111494219624be84 (patch)
tree047153c569f731aaffeb859a8029d386aab4edff /meta/recipes-devtools/go/go_1.17.7.bb
parenteb72e3c3815bf402d2c993ef7692bee27e775372 (diff)
downloadpoky-3858855d0d9cdabc605eab76111494219624be84.tar.gz
go: upgrade 1.17.6 -> 1.17.7
(From OE-Core rev: e1a1b201c4a850ae116d88975df3fdab4dea6945) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.17.7.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.17.7.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.17.7.bb b/meta/recipes-devtools/go/go_1.17.7.bb
new file mode 100644
index 0000000000..34dc89bb0c
--- /dev/null
+++ b/meta/recipes-devtools/go/go_1.17.7.bb
@@ -0,0 +1,17 @@
1require go-${PV}.inc
2require go-target.inc
3
4inherit linuxloader
5
6export GOBUILDMODE=""
7export GO_LDSO = "${@get_linuxloader(d)}"
8export CC_FOR_TARGET = "gcc"
9export CXX_FOR_TARGET = "g++"
10
11# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
12# variants.
13python() {
14 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv32' in d.getVar('TARGET_ARCH',True):
15 d.appendVar('INSANE_SKIP:%s' % d.getVar('PN',True), " textrel")
16}
17