summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.17.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-12-07 14:07:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-08 20:22:11 +0000
commit20846102156418f187e977ab0bbd557525bbc4e1 (patch)
treec76e2a2f3da6597d50d52a1d82002e7f9e631806 /meta/recipes-devtools/go/go_1.17.4.bb
parent4ca1132b28bf976550e4ca08230de630eed358ed (diff)
downloadpoky-20846102156418f187e977ab0bbd557525bbc4e1.tar.gz
go: update 1.17.3 -> 1.17.4
(From OE-Core rev: aa1dd053503f464dcc920e064a6d8ead6772cab2) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.17.4.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.17.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.17.4.bb b/meta/recipes-devtools/go/go_1.17.4.bb
new file mode 100644
index 0000000000..34dc89bb0c
--- /dev/null
+++ b/meta/recipes-devtools/go/go_1.17.4.bb
@@ -0,0 +1,17 @@
1require go-${PV}.inc
2require go-target.inc
3
4inherit linuxloader
5
6export GOBUILDMODE=""
7export GO_LDSO = "${@get_linuxloader(d)}"
8export CC_FOR_TARGET = "gcc"
9export CXX_FOR_TARGET = "g++"
10
11# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
12# variants.
13python() {
14 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv32' in d.getVar('TARGET_ARCH',True):
15 d.appendVar('INSANE_SKIP:%s' % d.getVar('PN',True), " textrel")
16}
17