summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.16.15.bb
diff options
context:
space:
mode:
authorChee Yang Lee <chee.yang.lee@intel.com>2022-03-18 17:50:11 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-04-03 20:49:03 +0100
commitc009c20ef2c4217921a439909c2a350097262c2f (patch)
treebe3a83a289427eb4ea4d8c42d841c6d07b5d602a /meta/recipes-devtools/go/go_1.16.15.bb
parente3d1922620e2210998659e73a98a4122b4373688 (diff)
downloadpoky-c009c20ef2c4217921a439909c2a350097262c2f.tar.gz
go: update to 1.16.15
go1.16.15 (released 2022-03-03) includes a security fix to the regexp/syntax package, as well as bug fixes to the compiler, runtime, the go command, and to the net package. See the Go 1.16.15 milestone on our issue tracker for detai ls. (From OE-Core rev: 3462c7680137a9ef5f683161d39caf19f87a932a) Signed-off-by: Chee Yang Lee <chee.yang.lee@intel.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.16.15.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.16.15.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.16.15.bb b/meta/recipes-devtools/go/go_1.16.15.bb
new file mode 100644
index 0000000000..4e9e0ebec8
--- /dev/null
+++ b/meta/recipes-devtools/go/go_1.16.15.bb
@@ -0,0 +1,17 @@
1require go-${PV}.inc
2require go-target.inc
3
4inherit linuxloader
5
6export GOBUILDMODE=""
7export GO_LDSO = "${@get_linuxloader(d)}"
8export CC_FOR_TARGET = "gcc"
9export CXX_FOR_TARGET = "g++"
10
11# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
12# variants.
13python() {
14 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv32' in d.getVar('TARGET_ARCH',True):
15 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
16}
17