summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.12.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-03-07 16:10:55 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-03-09 14:43:11 +0000
commite53aa46f435d68706d042af17bf629a16f18556c (patch)
tree57aced42db7e12c5cc90a385231c7b42272adda8 /meta/recipes-devtools/go/go_1.12.bb
parentd5cfad0848d51191ff2555c4fe07554aec146f18 (diff)
downloadpoky-e53aa46f435d68706d042af17bf629a16f18556c.tar.gz
go: Add recipes for 1.12 release and make it default
- Refresh patches - Enable GOCACHE required as of Go 1.12 (From OE-Core rev: f559fd6df2978f9093672794420eada2b7452987) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go_1.12.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.12.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.12.bb b/meta/recipes-devtools/go/go_1.12.bb
new file mode 100644
index 0000000000..42cdb0430a
--- /dev/null
+++ b/meta/recipes-devtools/go/go_1.12.bb
@@ -0,0 +1,14 @@
1require go-${PV}.inc
2require go-target.inc
3
4export GOBUILDMODE=""
5
6# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
7# doesn't support -buildmode=pie, so skip the QA checking for mips and its
8# variants.
9python() {
10 if 'mips' in d.getVar('TARGET_ARCH'):
11 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
12 else:
13 d.setVar('GOBUILDMODE', 'pie')
14}