diff options
author | Soumya Sambu <soumya.sambu@windriver.com> | 2024-03-15 11:24:22 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-03-18 12:21:45 +0000 |
commit | 1e4de6edc6fd644d375ad8c402af08fda4c26a65 (patch) | |
tree | 95104495d6f7f44e3112947a99ca097bda51fdc3 /meta/recipes-devtools/go/go-native_1.22.1.bb | |
parent | 4fd93a7be408e3a9bc06adbaaf162bf27505934f (diff) | |
download | poky-1e4de6edc6fd644d375ad8c402af08fda4c26a65.tar.gz |
go: Upgrade 1.22.0 -> 1.22.1
Upgrade to latest 1.22.x release [1]:
$git log --oneline go1.22.0..go1.22.1
db6097f8cb (tag: go1.22.1, origin/release-branch.go1.22) [release-branch.go1.22] go1.22.1
041a47712e [release-branch.go1.22] net/textproto, mime/multipart: avoid unbounded read in MIME header
3a855208e3 [release-branch.go1.22] net/http, net/http/cookiejar: avoid subdomain matches on IPv6 zones
337b8e9cbf [release-branch.go1.22] crypto/x509: make sure pub key is non-nil before interface conversion
16830ab48a [release-branch.go1.22] net/http: add missing call to decConnsPerHost
056b0edcb8 [release-branch.go1.22] html/template: escape additional tokens in MarshalJSON errors
f73eba76a0 [release-branch.go1.22] net: work around runtime scheduler starvation on js and wasip1
5330cd225b [release-branch.go1.22] net/mail: properly handle special characters in phrase and obs-phrase
d8c4239f08 [release-branch.go1.22] cmd/go/internal/modcmd: correctly filter out main modules in verify
c33adf44ff [release-branch.go1.22] cmd/trace/v2,internal/trace: use correct frame for identifying goroutines
3b71998078 [release-branch.go1.22] go/types, types2: ensure that Alias.actual is set in NewAlias
8fe2ad6494 [release-branch.go1.22] runtime/internal/atomic: correct GOARM=7 guard at a DMB instruction
686662f3a4 [release-branch.go1.22] cmd/compile: make jump table symbol static
6cbe522fe1 [release-branch.go1.22] cmd/compile: fail noder.LookupFunc gracefully if function generic
fb86598cd3 [release-branch.go1.22] cmd/compile: accept -lang=go1 as -lang=go1.0
6fbd01a711 [release-branch.go1.22] runtime: don't call traceReadCPU on the system stack
d6a271939f [release-branch.go1.22] cmd/cgo/internal/testsanitizers: disable location checking for clang
20107e05a6 [release-branch.go1.22] internal/testenv: support the LUCI mobile builders in tests
53d1b73dff [release-branch.go1.22] internal/testenv: allow "-noopt" anywhere in builder name in test
dd31ad7e9f [release-branch.go1.22] spec: fix typo in year (it's 2024 now)
[1] https://github.com/golang/go/compare/go1.22.0...go1.22.1
(From OE-Core rev: 423f875e10707b583f34dde625301c702c49e9d9)
Signed-off-by: Soumya Sambu <soumya.sambu@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-native_1.22.1.bb')
-rw-r--r-- | meta/recipes-devtools/go/go-native_1.22.1.bb | 58 |
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-native_1.22.1.bb b/meta/recipes-devtools/go/go-native_1.22.1.bb new file mode 100644 index 0000000000..ddf25b2c9b --- /dev/null +++ b/meta/recipes-devtools/go/go-native_1.22.1.bb | |||
@@ -0,0 +1,58 @@ | |||
1 | # This recipe builds a native Go (written in Go) by first building an old Go 1.4 | ||
2 | # (written in C). However this old Go does not support all hosts platforms. | ||
3 | |||
4 | require go-${PV}.inc | ||
5 | |||
6 | inherit native | ||
7 | |||
8 | SRC_URI += "https://dl.google.com/go/go1.4-bootstrap-20171003.tar.gz;name=bootstrap;subdir=go1.4" | ||
9 | SRC_URI[bootstrap.sha256sum] = "f4ff5b5eb3a3cae1c993723f3eab519c5bae18866b5e5f96fe1102f0cb5c3e52" | ||
10 | |||
11 | export GOOS = "${BUILD_GOOS}" | ||
12 | export GOARCH = "${BUILD_GOARCH}" | ||
13 | CC = "${@d.getVar('BUILD_CC').strip()}" | ||
14 | |||
15 | GOMAKEARGS ?= "--no-banner" | ||
16 | |||
17 | do_configure() { | ||
18 | cd ${WORKDIR}/go1.4/go/src | ||
19 | CGO_ENABLED=0 GOROOT=${WORKDIR}/go1.4/go ./make.bash | ||
20 | } | ||
21 | |||
22 | do_compile() { | ||
23 | export GOROOT_FINAL="${libdir_native}/go" | ||
24 | export GOROOT_BOOTSTRAP="${WORKDIR}/go1.4/go" | ||
25 | |||
26 | cd src | ||
27 | ./make.bash ${GOMAKEARGS} | ||
28 | cd ${B} | ||
29 | } | ||
30 | do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin" | ||
31 | |||
32 | make_wrapper() { | ||
33 | rm -f ${D}${bindir}/$2$3 | ||
34 | cat <<END >${D}${bindir}/$2$3 | ||
35 | #!/bin/bash | ||
36 | here=\`dirname \$0\` | ||
37 | export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}" | ||
38 | \$here/../lib/go/bin/$1 "\$@" | ||
39 | END | ||
40 | chmod +x ${D}${bindir}/$2 | ||
41 | } | ||
42 | |||
43 | do_install() { | ||
44 | install -d ${D}${libdir}/go | ||
45 | cp --preserve=mode,timestamps -R ${B}/pkg ${D}${libdir}/go/ | ||
46 | install -d ${D}${libdir}/go/src | ||
47 | (cd ${S}/src; for d in *; do \ | ||
48 | [ -d $d ] && cp -a ${S}/src/$d ${D}${libdir}/go/src/; \ | ||
49 | done) | ||
50 | find ${D}${libdir}/go/src -depth -type d -name testdata -exec rm -rf {} \; | ||
51 | install -d ${D}${bindir} ${D}${libdir}/go/bin | ||
52 | for f in ${B}/bin/* | ||
53 | do | ||
54 | base=`basename $f` | ||
55 | install -m755 $f ${D}${libdir}/go/bin | ||
56 | make_wrapper $base $base | ||
57 | done | ||
58 | } | ||