summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-native_1.16.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-23 20:13:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-26 15:21:20 +0000
commitcedb3aa8173a9443fec5adee8419d2f505bc304c (patch)
tree2a2f9e7b7c05bc063487253b30248fa9df727794 /meta/recipes-devtools/go/go-native_1.16.bb
parent510406ddf54613b691cd59efa12f70848b5101b5 (diff)
downloadpoky-cedb3aa8173a9443fec5adee8419d2f505bc304c.tar.gz
go: Upgrade compiler to 1.16 major release
Revert a CC/CXX check [1] which wont work with OE settings Forward port needed patches forward Details releaase notes are here [2] [1] https://go-review.googlesource.com/c/go/+/228517/ [2] https://golang.org/doc/go1.16 (From OE-Core rev: 5c41c6ed4e2e70d18b32c460b8c8e1aadd54584f) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-native_1.16.bb')
-rw-r--r--meta/recipes-devtools/go/go-native_1.16.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-native_1.16.bb b/meta/recipes-devtools/go/go-native_1.16.bb
new file mode 100644
index 0000000000..f14892cdb0
--- /dev/null
+++ b/meta/recipes-devtools/go/go-native_1.16.bb
@@ -0,0 +1,59 @@
1# This recipe builds a native Go (written in Go) by first building an old Go 1.4
2# (written in C). However this old Go does not support all hosts platforms.
3
4require go-${PV}.inc
5
6inherit native
7
8SRC_URI_append = " https://dl.google.com/go/go1.4-bootstrap-20171003.tar.gz;name=bootstrap;subdir=go1.4"
9SRC_URI[bootstrap.sha256sum] = "f4ff5b5eb3a3cae1c993723f3eab519c5bae18866b5e5f96fe1102f0cb5c3e52"
10
11export GOOS = "${BUILD_GOOS}"
12export GOARCH = "${BUILD_GOARCH}"
13CC = "${@d.getVar('BUILD_CC').strip()}"
14
15GOMAKEARGS ?= "--no-banner"
16
17do_configure() {
18 cd ${WORKDIR}/go1.4/go/src
19 CGO_ENABLED=0 GOROOT=${WORKDIR}/go1.4/go ./make.bash
20}
21
22do_compile() {
23 export GOROOT_FINAL="${libdir_native}/go"
24 export GOROOT_BOOTSTRAP="${WORKDIR}/go1.4/go"
25
26 cd src
27 ./make.bash ${GOMAKEARGS}
28 cd ${B}
29}
30do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin"
31do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin"
32
33make_wrapper() {
34 rm -f ${D}${bindir}/$2$3
35 cat <<END >${D}${bindir}/$2$3
36#!/bin/bash
37here=\`dirname \$0\`
38export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
39\$here/../lib/go/bin/$1 "\$@"
40END
41 chmod +x ${D}${bindir}/$2
42}
43
44do_install() {
45 install -d ${D}${libdir}/go
46 cp --preserve=mode,timestamps -R ${B}/pkg ${D}${libdir}/go/
47 install -d ${D}${libdir}/go/src
48 (cd ${S}/src; for d in *; do \
49 [ -d $d ] && cp -a ${S}/src/$d ${D}${libdir}/go/src/; \
50 done)
51 find ${D}${libdir}/go/src -depth -type d -name testdata -exec rm -rf {} \;
52 install -d ${D}${bindir} ${D}${libdir}/go/bin
53 for f in ${B}/bin/*
54 do
55 base=`basename $f`
56 install -m755 $f ${D}${libdir}/go/bin
57 make_wrapper $base $base
58 done
59}