summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-native_1.16.8.bb
diff options
context:
space:
mode:
authorPavel Zhukov <pavel.zhukov@huawei.com>2021-11-24 15:08:55 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-05 12:35:43 +0000
commit87fd2dceb18e86091734827e4e4333bd4917601f (patch)
treef30bcd8c2679a5e1afa4762a39b30a7a5ec788d2 /meta/recipes-devtools/go/go-native_1.16.8.bb
parentfa99c5a942224db0a9e571b57d68f031a24cc1ba (diff)
downloadpoky-87fd2dceb18e86091734827e4e4333bd4917601f.tar.gz
go: upgrade 1.16.8 -> 1.16.10
The release includes fixes for CVE-2021-41771 and CVE-2021-41772 (From OE-Core rev: 0df36f324a2dc17f18066efc5c130231158b5d24) Signed-off-by: Pavel Zhukov <pavel.zhukov@huawei.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> This release also contains a fix for CVE-2021-38297 and the changes are minor, so backport the uprev rather than manually backporting individual commits. CVE: CVE-2021-38297 Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-native_1.16.8.bb')
-rw-r--r--meta/recipes-devtools/go/go-native_1.16.8.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta/recipes-devtools/go/go-native_1.16.8.bb b/meta/recipes-devtools/go/go-native_1.16.8.bb
deleted file mode 100644
index f14892cdb0..0000000000
--- a/meta/recipes-devtools/go/go-native_1.16.8.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1# This recipe builds a native Go (written in Go) by first building an old Go 1.4
2# (written in C). However this old Go does not support all hosts platforms.
3
4require go-${PV}.inc
5
6inherit native
7
8SRC_URI_append = " https://dl.google.com/go/go1.4-bootstrap-20171003.tar.gz;name=bootstrap;subdir=go1.4"
9SRC_URI[bootstrap.sha256sum] = "f4ff5b5eb3a3cae1c993723f3eab519c5bae18866b5e5f96fe1102f0cb5c3e52"
10
11export GOOS = "${BUILD_GOOS}"
12export GOARCH = "${BUILD_GOARCH}"
13CC = "${@d.getVar('BUILD_CC').strip()}"
14
15GOMAKEARGS ?= "--no-banner"
16
17do_configure() {
18 cd ${WORKDIR}/go1.4/go/src
19 CGO_ENABLED=0 GOROOT=${WORKDIR}/go1.4/go ./make.bash
20}
21
22do_compile() {
23 export GOROOT_FINAL="${libdir_native}/go"
24 export GOROOT_BOOTSTRAP="${WORKDIR}/go1.4/go"
25
26 cd src
27 ./make.bash ${GOMAKEARGS}
28 cd ${B}
29}
30do_compile[dirs] =+ "${GOTMPDIR} ${B}/bin"
31do_compile[cleandirs] += "${GOTMPDIR} ${B}/bin"
32
33make_wrapper() {
34 rm -f ${D}${bindir}/$2$3
35 cat <<END >${D}${bindir}/$2$3
36#!/bin/bash
37here=\`dirname \$0\`
38export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
39\$here/../lib/go/bin/$1 "\$@"
40END
41 chmod +x ${D}${bindir}/$2
42}
43
44do_install() {
45 install -d ${D}${libdir}/go
46 cp --preserve=mode,timestamps -R ${B}/pkg ${D}${libdir}/go/
47 install -d ${D}${libdir}/go/src
48 (cd ${S}/src; for d in *; do \
49 [ -d $d ] && cp -a ${S}/src/$d ${D}${libdir}/go/src/; \
50 done)
51 find ${D}${libdir}/go/src -depth -type d -name testdata -exec rm -rf {} \;
52 install -d ${D}${bindir} ${D}${libdir}/go/bin
53 for f in ${B}/bin/*
54 do
55 base=`basename $f`
56 install -m755 $f ${D}${libdir}/go/bin
57 make_wrapper $base $base
58 done
59}