diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2018-08-30 14:27:35 -0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-09-04 11:03:56 +0100 |
commit | de7194039a35a99868e4818e3e0ea9e76eeb8380 (patch) | |
tree | ae01f8759a4b8d7d773bef4079996df2b4ea4425 /meta/recipes-devtools/go/go-dep_0.5.0.bb | |
parent | 235e7945190d4a8e99cbdd79ea276936a5fb90f1 (diff) | |
download | poky-de7194039a35a99868e4818e3e0ea9e76eeb8380.tar.gz |
go-dep: Update 0.4.1 -> 0.5.0
NEW FEATURES:
- Add CI tests against go1.10. Drop support for go1.8. (#1620).
- Added install.sh script. (#1533).
- List out of date projects in dep status (#1553).
- Enabled opt-in persistent caching via DEPCACHEAGE env var. (#1711).
- Allow DEPPROJECTROOT environment variable to supersede GOPATH
deduction and explicitly set the current project's root (#1883).
- dep ensure now explains what changes to the code or Gopkg.toml have
induced solving (#1912).
- Hash digests of vendor contents are now stored in Gopkg.lock, and
the contents of vendor are only rewritten on change or hash
mismatch (#1912).
- Added support for ppc64/ppc64le.
- New subcommand dep check quickly reports if imports, Gopkg.toml,
Gopkg.lock, and vendor are out of sync (#1932).
BUG FIXES:
- Excise certain git-related environment variables. (#1872)
IMPROVEMENTS:
- Add template operations support in dep status template output (#1549).
- Reduce network access by trusting local source information and only
pulling from upstream when necessary (#1250).
- Update our dependency on Masterminds/semver to follow upstream again
now that Masterminds/semver#67 is merged(#1792).
- inputs-digest was removed from Gopkg.lock (#1912).
- Hash digests of vendor contents are now stored in Gopkg.lock, and
the contents of vendor are only rewritten on change or hash
mismatch (#1912).
- Don't exclude Godeps folder (#1822).
- Add project-package relationship graph support in graphviz (#1588).
- Limit concurrency of dep status to avoid hitting open file
limits (#1923).
(From OE-Core rev: 165da89292f81d236e4e8e652500b8879c2ad9be)
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-dep_0.5.0.bb')
-rw-r--r-- | meta/recipes-devtools/go/go-dep_0.5.0.bb | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-dep_0.5.0.bb b/meta/recipes-devtools/go/go-dep_0.5.0.bb new file mode 100644 index 0000000000..f0ce60a8ec --- /dev/null +++ b/meta/recipes-devtools/go/go-dep_0.5.0.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "Dependency management tool for Golang" | ||
2 | HOMEPAGE = "https://github.com/golang/dep" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=1bad315647751fab0007812f70d42c0d" | ||
5 | |||
6 | GO_IMPORT = "github.com/golang/dep" | ||
7 | SRC_URI = "git://${GO_IMPORT} \ | ||
8 | file://0001-Add-support-for-mips-mips64.patch;patchdir=src/github.com/golang/dep \ | ||
9 | " | ||
10 | |||
11 | # Points to 0.5.0 tag | ||
12 | SRCREV = "224a564abe296670b692fe08bb63a3e4c4ad7978" | ||
13 | |||
14 | inherit go | ||
15 | |||
16 | GO_INSTALL = "${GO_IMPORT}/cmd/dep" | ||
17 | |||
18 | RDEPENDS_${PN}-dev += "bash" | ||
19 | |||
20 | BBCLASSEXTEND = "native nativesdk" | ||
21 | |||
22 | # for x86 ends with textrel in ${PN} | ||
23 | # http://errors.yoctoproject.org/Errors/Details/185630/ | ||
24 | # ERROR: QA Issue: ELF binary '/work/i586-oe-linux/go-dep/0.4.1-r0/packages-split/go-dep/usr/bin/dep' has relocations in .text [textrel] | ||
25 | INSANE_SKIP_${PN} += "textrel" | ||
26 | |||
27 | # for aarch64 ends with textrel in ${PN}-ptest | ||
28 | # http://errors.yoctoproject.org/Errors/Details/185632/ | ||
29 | # ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/go-dep/0.4.1-r0/packages-split/go-dep-ptest/usr/lib/go-dep/ptest/github.com/golang/dep/cmd/dep/dep.test' has relocations in .text [textrel] | ||
30 | INSANE_SKIP_${PN}-ptest += "textrel" | ||