summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
diff options
context:
space:
mode:
authorMatt Madison <matt@madison.systems>2018-03-04 13:09:34 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-06 06:43:10 -0800
commit8701fe54a801705a99136f3a5d2afb5e47d37a29 (patch)
tree62a0f3a58f9572898317f1f7616376775c1fe9d9 /meta/recipes-devtools/go/go-cross-canadian_1.9.bb
parent3ffafcd9cf18051074b3a6298f754f34768e36dc (diff)
downloadpoky-8701fe54a801705a99136f3a5d2afb5e47d37a29.tar.gz
go: disable PIE CFLAGS for nativesdk and cross-canadian builds
The statically-linked Go code in the toolchain is not compatible with PIE, so disable its use in the C compiler during the toolchain build. (From OE-Core rev: cc7b179917c715b29822200fe91ecd755a5750e6) Signed-off-by: Matt Madison <matt@madison.systems> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-cross-canadian_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go-cross-canadian_1.9.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/go/go-cross-canadian_1.9.bb b/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
index 0306fdf684..367a967056 100644
--- a/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
+++ b/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
@@ -3,8 +3,8 @@ require go-${PV}.inc
3 3
4export GOHOSTOS_CROSS = "${HOST_GOOS}" 4export GOHOSTOS_CROSS = "${HOST_GOOS}"
5export GOHOSTARCH_CROSS = "${HOST_GOARCH}" 5export GOHOSTARCH_CROSS = "${HOST_GOARCH}"
6export CC_FOR_TARGET = "${HOST_PREFIX}gcc --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE}" 6export CC_FOR_TARGET = "${HOST_PREFIX}gcc --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE} ${SECURITY_NOPIE_CFLAGS}"
7export CXX_FOR_TARGET = "${HOST_PREFIX}g++ --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE}" 7export CXX_FOR_TARGET = "${HOST_PREFIX}g++ --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE} ${SECURITY_NOPIE_CFLAGS}"
8 8
9do_compile_prepend() { 9do_compile_prepend() {
10 export GOBIN="${B}/bin" 10 export GOBIN="${B}/bin"