summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
diff options
context:
space:
mode:
authorMatt Madison <matt@madison.systems>2018-03-04 13:09:25 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-06 06:43:10 -0800
commit7a4ca89b557648d9aae30b405f6be09b4a383abe (patch)
treefb131b91c54b054ad525566d2da014abaa7c8f9f /meta/recipes-devtools/go/go-cross-canadian_1.9.bb
parent26227695b350056225e9d309defdcd66573b79bb (diff)
downloadpoky-7a4ca89b557648d9aae30b405f6be09b4a383abe.tar.gz
go: update go 1.9 -> go 1.10
* Patches and recipes reworked for go 1.10's significant changes to its bootstrap and build steps. * Update go1.4 source tarball used for go-native bootstrapping to the version recommended in the current go documentation * Remove test data from installed sources to eliminate some packaging QA warnings * Set GOCACHE to 'off' to disable 1.10's build caching in the go recipes and bbclass * Update go_do_compile to compile both static and dynamic objects dynamic linking is in use, since go1.10's build tool is pickier about this (From OE-Core rev: 4fd749ca6450a4870be1c1e13802f084b6eb0db6) Signed-off-by: Matt Madison <matt@madison.systems> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-cross-canadian_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go-cross-canadian_1.9.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-cross-canadian_1.9.bb b/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
index 7ac9449e47..0306fdf684 100644
--- a/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
+++ b/meta/recipes-devtools/go/go-cross-canadian_1.9.bb
@@ -1,2 +1,12 @@
1require go-cross-canadian.inc 1require go-cross-canadian.inc
2require go-${PV}.inc 2require go-${PV}.inc
3
4export GOHOSTOS_CROSS = "${HOST_GOOS}"
5export GOHOSTARCH_CROSS = "${HOST_GOARCH}"
6export CC_FOR_TARGET = "${HOST_PREFIX}gcc --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE}"
7export CXX_FOR_TARGET = "${HOST_PREFIX}g++ --sysroot=${STAGING_DIR_HOST}${SDKPATHNATIVE}"
8
9do_compile_prepend() {
10 export GOBIN="${B}/bin"
11 export TMPDIR="$GOTMPDIR"
12}