diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2022-01-19 11:40:54 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-01-20 11:57:29 +0000 |
commit | 11b1b4b29c6cbec2855b2cfd7a0e28ecdc81ea95 (patch) | |
tree | cbecc52a3c95dea5a22b6f3b68b42b2c08dfbb76 /meta/recipes-devtools/go/go-binary-native_1.17.6.bb | |
parent | 078a1a64edb1ff03f1ab47285d44a1c2926a9673 (diff) | |
download | poky-11b1b4b29c6cbec2855b2cfd7a0e28ecdc81ea95.tar.gz |
go: upgrade 1.17.5 -> 1.17.6
(From OE-Core rev: f48e276ec340acc1c086dff3d18f92d822e31351)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/go/go-binary-native_1.17.6.bb')
-rw-r--r-- | meta/recipes-devtools/go/go-binary-native_1.17.6.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go-binary-native_1.17.6.bb b/meta/recipes-devtools/go/go-binary-native_1.17.6.bb new file mode 100644 index 0000000000..674f9176af --- /dev/null +++ b/meta/recipes-devtools/go/go-binary-native_1.17.6.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | # This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org. | ||
2 | |||
3 | SUMMARY = "Go programming language compiler (upstream binary for bootstrap)" | ||
4 | HOMEPAGE = " http://golang.org/" | ||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707" | ||
7 | |||
8 | PROVIDES = "go-native" | ||
9 | |||
10 | SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}" | ||
11 | SRC_URI[go_linux_amd64.sha256sum] = "231654bbf2dab3d86c1619ce799e77b03d96f9b50770297c8f4dff8836fc8ca2" | ||
12 | SRC_URI[go_linux_arm64.sha256sum] = "82c1a033cce9bc1b47073fd6285233133040f0378439f3c4659fe77cc534622a" | ||
13 | |||
14 | UPSTREAM_CHECK_URI = "https://golang.org/dl/" | ||
15 | UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux" | ||
16 | |||
17 | S = "${WORKDIR}/go" | ||
18 | |||
19 | inherit goarch native | ||
20 | |||
21 | do_compile() { | ||
22 | : | ||
23 | } | ||
24 | |||
25 | make_wrapper() { | ||
26 | rm -f ${D}${bindir}/$1 | ||
27 | cat <<END >${D}${bindir}/$1 | ||
28 | #!/bin/bash | ||
29 | here=\`dirname \$0\` | ||
30 | export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}" | ||
31 | \$here/../lib/go/bin/$1 "\$@" | ||
32 | END | ||
33 | chmod +x ${D}${bindir}/$1 | ||
34 | } | ||
35 | |||
36 | do_install() { | ||
37 | find ${S} -depth -type d -name testdata -exec rm -rf {} + | ||
38 | |||
39 | install -d ${D}${bindir} ${D}${libdir}/go | ||
40 | cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/ | ||
41 | |||
42 | for f in ${S}/bin/* | ||
43 | do | ||
44 | make_wrapper `basename $f` | ||
45 | done | ||
46 | } | ||