diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-09-05 22:38:32 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-09-10 12:13:06 +0100 |
commit | 2b7043ca09e1c4262757b6c25c84291640708765 (patch) | |
tree | b8fb4f769ac1514c48b57f2eb38b3be4b74b8844 /meta/recipes-devtools/gdb/gdb_8.2.bb | |
parent | 3578a05aed3899f7a1fa4c843233a86fe6952898 (diff) | |
download | poky-2b7043ca09e1c4262757b6c25c84291640708765.tar.gz |
gdb: Update to 8.2
* https://sourceware.org/ml/gdb-announce/2018/msg00003.html
* Support RISC-V
(From OE-Core rev: 1d9d117e8eee2d3b9802384cb93155aea487f002)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_8.2.bb')
-rw-r--r-- | meta/recipes-devtools/gdb/gdb_8.2.bb | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_8.2.bb b/meta/recipes-devtools/gdb/gdb_8.2.bb new file mode 100644 index 0000000000..c6eac84dd8 --- /dev/null +++ b/meta/recipes-devtools/gdb/gdb_8.2.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | require gdb.inc | ||
2 | require gdb-${PV}.inc | ||
3 | |||
4 | inherit python3-dir | ||
5 | |||
6 | EXTRA_OEMAKE_append_libc-musl = "\ | ||
7 | gt_cv_func_gnugettext1_libc=yes \ | ||
8 | gt_cv_func_gnugettext2_libc=yes \ | ||
9 | gl_cv_func_working_strerror=yes \ | ||
10 | gl_cv_func_strerror_0_works=yes \ | ||
11 | gl_cv_func_gettimeofday_clobber=no \ | ||
12 | " | ||
13 | |||
14 | do_configure_prepend() { | ||
15 | if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then | ||
16 | cat > ${WORKDIR}/python << EOF | ||
17 | #!/bin/sh | ||
18 | case "\$2" in | ||
19 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;; | ||
20 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;; | ||
21 | --exec-prefix) echo "${exec_prefix}" ;; | ||
22 | *) exit 1 ;; | ||
23 | esac | ||
24 | exit 0 | ||
25 | EOF | ||
26 | chmod +x ${WORKDIR}/python | ||
27 | fi | ||
28 | } | ||
29 | CPPFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday -Drpl_stat=stat" | ||