summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_8.0.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-11-12 10:55:50 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-03 09:26:38 +0000
commit5809c8fc85f3ead43ec7c2c7f1186ddbd04719b3 (patch)
tree6fde9627b7b26fd422318f741e6a7d4672eae4b7 /meta/recipes-devtools/gdb/gdb_8.0.1.bb
parent43c16984656bf51e1acfc7d1abd87cf883c7485b (diff)
downloadpoky-5809c8fc85f3ead43ec7c2c7f1186ddbd04719b3.tar.gz
gdb: Upgrade to 8.0.1
Minor bugfix release, details are here https://sourceware.org/ml/gdb-announce/2017/msg00004.html (From OE-Core rev: 9339724de14c8bfc1baa71e4ed687410aed1a812) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_8.0.1.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_8.0.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_8.0.1.bb b/meta/recipes-devtools/gdb/gdb_8.0.1.bb
new file mode 100644
index 0000000000..ea8fef122c
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_8.0.1.bb
@@ -0,0 +1,27 @@
1require gdb.inc
2require gdb-${PV}.inc
3
4inherit python3-dir
5
6EXTRA_OEMAKE_append_libc-musl = "\
7 gt_cv_func_gnugettext1_libc=yes \
8 gt_cv_func_gnugettext2_libc=yes \
9 gl_cv_func_gettimeofday_clobber=no \
10 "
11
12do_configure_prepend() {
13 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
14 cat > ${WORKDIR}/python << EOF
15#!/bin/sh
16case "\$2" in
17 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
18 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
19 --exec-prefix) echo "${exec_prefix}" ;;
20 *) exit 1 ;;
21esac
22exit 0
23EOF
24 chmod +x ${WORKDIR}/python
25 fi
26}
27CFLAGS_append_libc-musl = " -Drpl_gettimeofday=gettimeofday"