summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.8.1.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-04 11:39:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-09 10:21:19 +0000
commitb78e3e3b27a2e92acfb2c7d7d9f8779c60b2c6dc (patch)
tree7313d86599ec0ae23540266381077e4efb1d05d9 /meta/recipes-devtools/gdb/gdb_7.8.1.bb
parent593f14b2e3d1474d0c21d8d872dc7685163ffad2 (diff)
downloadpoky-b78e3e3b27a2e92acfb2c7d7d9f8779c60b2c6dc.tar.gz
gdb: 7.7.1 -> 7.8.1
Drop patch merged upstream. Also drop old arm/thumb patch which breaks the compile on arm. We've had this since 2010 (or longer) and the issue has likely been fixed upstream by now. If not someone with more knowledge will need to figure out the fix against the current codebase. (From OE-Core rev: b171f30701aae36f8512ed0b7472984671589c5f) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.8.1.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.8.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.8.1.bb b/meta/recipes-devtools/gdb/gdb_7.8.1.bb
new file mode 100644
index 0000000000..1abc9d8e76
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_7.8.1.bb
@@ -0,0 +1,24 @@
1require gdb.inc
2require gdb-${PV}.inc
3
4inherit python-dir
5
6PACKAGECONFIG ??= ""
7PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
8PACKAGECONFIG[babeltrace] = "--with-babeltrace,--without-babeltrace,babeltrace"
9
10do_configure_prepend() {
11 if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
12 cat > ${WORKDIR}/python << EOF
13#!/bin/sh
14case "\$2" in
15 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
16 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
17 --exec-prefix) echo "${exec_prefix}" ;;
18 *) exit 1 ;;
19esac
20exit 0
21EOF
22 chmod +x ${WORKDIR}/python
23 fi
24}