summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_7.6.1.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2013-10-16 17:05:36 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-10-26 15:59:11 +0100
commit30bafdc1c75ad7efee824b4e84c147112d771c5a (patch)
tree50a42bd2db1a0d06fbea47bee33cef7153459262 /meta/recipes-devtools/gdb/gdb_7.6.1.bb
parent4525157d979867a4e834568180d8f05b46398bea (diff)
downloadpoky-30bafdc1c75ad7efee824b4e84c147112d771c5a.tar.gz
gdb: upgrade to 7.6.1
(From OE-Core rev: d7014db37a62bad02a424e6d5f052abbd3c4d2ca) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.6.1.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_7.6.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.6.1.bb b/meta/recipes-devtools/gdb/gdb_7.6.1.bb
new file mode 100644
index 0000000000..e86447121b
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_7.6.1.bb
@@ -0,0 +1,23 @@
1require gdb.inc
2require gdb-${PV}.inc
3
4inherit python-dir
5
6PACKAGECONFIG ??= ""
7PACKAGECONFIG[python] = "--with-python=${WORKDIR}/python,--without-python,python"
8
9do_configure_prepend() {
10 if [ -n "${@base_contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then
11 cat > ${WORKDIR}/python << EOF
12#!/bin/sh
13case "\$2" in
14 --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;;
15 --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;;
16 --exec-prefix) echo "${exec_prefix}" ;;
17 *) exit 1 ;;
18esac
19exit 0
20EOF
21 chmod +x ${WORKDIR}/python
22 fi
23}