diff options
author | Alexander Kanavin <alexander.kanavin@linux.intel.com> | 2016-06-02 12:25:54 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-06-03 13:13:27 +0100 |
commit | 609bf2ecf500404899cfe370ffa5ee4110eb2423 (patch) | |
tree | 91de95cd5d8ba4475821ba5f98bd0b1e9e198d77 /meta/recipes-devtools/gdb/gdb_7.11.bb | |
parent | ada03c326bf94b211e6cbf1ad8621c2c070ff962 (diff) | |
download | poky-609bf2ecf500404899cfe370ffa5ee4110eb2423.tar.gz |
gdb: move to Python 3
(From OE-Core rev: 675d11c73dc1f420c471af01a520f6a20d8a7337)
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_7.11.bb')
-rw-r--r-- | meta/recipes-devtools/gdb/gdb_7.11.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_7.11.bb b/meta/recipes-devtools/gdb/gdb_7.11.bb index ccc33b8656..f02e6431dd 100644 --- a/meta/recipes-devtools/gdb/gdb_7.11.bb +++ b/meta/recipes-devtools/gdb/gdb_7.11.bb | |||
@@ -1,15 +1,15 @@ | |||
1 | require gdb.inc | 1 | require gdb.inc |
2 | require gdb-${PV}.inc | 2 | require gdb-${PV}.inc |
3 | 3 | ||
4 | inherit python-dir | 4 | inherit python3-dir |
5 | 5 | ||
6 | do_configure_prepend() { | 6 | do_configure_prepend() { |
7 | if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then | 7 | if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then |
8 | cat > ${WORKDIR}/python << EOF | 8 | cat > ${WORKDIR}/python << EOF |
9 | #!/bin/sh | 9 | #!/bin/sh |
10 | case "\$2" in | 10 | case "\$2" in |
11 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;; | 11 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;; |
12 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;; | 12 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;; |
13 | --exec-prefix) echo "${exec_prefix}" ;; | 13 | --exec-prefix) echo "${exec_prefix}" ;; |
14 | *) exit 1 ;; | 14 | *) exit 1 ;; |
15 | esac | 15 | esac |